Records fine but no audio output from presonus studio



  • Need some help please.
    I have been using prosunus studio for a couple of years and thought I knew what I was doing!

    I have unplugged my audio interface hooked up the spark with the usb, installed the spark drivers and set it up in studio one..

    I pick a tone from the the app it sounds great. I create a track and start recording all levels look as they should.

    But when I try to use listen back to what I've recorded I get no audio at all, the mixer levels jump on screen telling me it's playing but I hear nothing at all from the spark,

    If I change the audio interface in studio one to asio for all I hear what I recorded through my pc headphones,

    What am I doing wrong and how do I get the spark to be the output playback for presonus?



  • @soup First, in Studio One, make sure that monitoring enabled for the guitar's track(s).

    Second, make sure that you are using the Spark's "Music Volume" knob to control the output from your computer (not the main "Output" knob). Despite its name, which is a bit misleading, the Spark's "Music Volume" knob doesn't just control backing track music volume -- it controls all audio volume from your computer, including your guitar itself. So, if you only want to listen to audio from your computer, then turn the Spark's main "Output" knob to zero, and use the Spark's "Music Volume" knob to control the guitar volume from your computer.



  • @blueingreen said in Records fine but no audio output from presonus studio:

    @soup First, in Studio One, make sure that monitoring enabled for the guitar's track(s).

    Second, make sure that you are using the Spark's "Music Volume" knob to control the output from your computer (not the main "Output" knob). Despite its name, which is a bit misleading, the Spark's "Music Volume" knob doesn't just control backing track music volume -- it controls all audio volume from your computer, including your guitar itself. So, if you only want to listen to audio from your computer, then turn the Spark's main "Output" knob to zero, and use the Spark's "Music Volume" knob to control the guitar volume from your computer.

    Thanks for the reply, tried all of this but still zero output



  • @soup Then maybe it's something in Studio One's output device settings, since the Spark's side is largely just using the correct volume (Music Volume). For my Studio One 5.0 general device settings, I have "Positive Grid USB Audio Device" set as the Audio Device, and don't remember doing anything special to make it work. Is that the device you are using?

    One thing to check in Studio One -- inside the recording's track for the guitar, there's the "Input" drop-down menu, if you click on that to get the drop-down, and then at the bottom of the drop-down, choose "Audio I/O Setup", a window pops-up showing initially the "Inputs" tab. Assuming your inputs are already working due to the VU activity, click on the "Outputs" tab to check the outputs. I have just one line for "Main" output, in which the far-right columns for "OUT 1" and "OUT 2" have "L" and "R" underneath, respectively. Are those columns activated with "L" and "R" or empty? If empty, then click on the empty blocks. Or, if you don't have any line at all, then do "Add (Stereo)" first to add the line.

    The Spark's output interfaces will be 1 and 2. You mention using another audio device -- if that device's outputs were something different, like 3 and 4, then Studio One could still be trying to use those, and so you may need to manually change them to 1 and 2 in the "Audio I/O Setup" (or add a new stereo line for 1 and 2). Then when you switch back to the other device, change them back to what they were before.



  • @blueingreen said in Records fine but no audio output from presonus studio:

    @soup Then maybe it's something in Studio One's output device settings, since the Spark's side is largely just using the correct volume (Music Volume). For my Studio One 5.0 general device settings, I have "Positive Grid USB Audio Device" set as the Audio Device, and don't remember doing anything special to make it work. Is that the device you are using?

    One thing to check in Studio One -- inside the recording's track for the guitar, there's the "Input" drop-down menu, if you click on that to get the drop-down, and then at the bottom of the drop-down, choose "Audio I/O Setup", a window pops-up showing initially the "Inputs" tab. Assuming your inputs are already working due to the VU activity, click on the "Outputs" tab to check the outputs. I have just one line for "Main" output, in which the far-right columns for "OUT 1" and "OUT 2" have "L" and "R" underneath, respectively. Are those columns activated with "L" and "R" or empty? If empty, then click on the empty blocks. Or, if you don't have any line at all, then do "Add (Stereo)" first to add the line.

    The Spark's output interfaces will be 1 and 2. You mention using another audio device -- if that device's outputs were something different, like 3 and 4, then Studio One could still be trying to use those, and so you may need to manually change them to 1 and 2 in the "Audio I/O Setup" (or add a new stereo line for 1 and 2). Then when you switch back to the other device, change them back to what they were before.

    So tried all this and still no dice
    Decided to troubleshoot starting from basics and getting the spark to work just as pc output before opening presonus.

    Select spark as output from pc audio settings no sound
    Try a new USB cable, no sound
    Try a different USB port on pc. Yes we have sound. And it sounds great!

    Open presonus.. No sound output. Close presonus check it's working just on pc. It's not no sound.
    Reboot pc try again.. No sound
    Try a different USB port again.. No sound
    Bash head against wallu... Turn off pc.



  • @soup Not really sure what else it could be. I don't remember doing anything special for my setup. The only other thing I noticed is in PG's native ASIO driver -- open its config by clicking on its status icon in the Windows system tray, and then clicking on the "Volume" tab, and then clicking on the "Output..." button. Make sure that the "Master" slider is not turned down or muted. It should be up by default, though, so not likely the issue -- but something to check.



  • @blueingreen said in Records fine but no audio output from presonus studio:

    @soup Not really sure what else it could be. I don't remember doing anything special for my setup. The only other thing I noticed is in PG's native ASIO driver -- open its config by clicking on its status icon in the Windows system tray, and then clicking on the "Volume" tab, and then clicking on the "Output..." button. Make sure that the "Master" slider is not turned down or muted. It should be up by default, though, so not likely the issue -- but something to check.

    So I had a double check and they was correct, so I uninstalled the device and the drivers reboot, reinstall drivers from positive grid site and it shows up in my sound devices, I select it and boom plays the music from the YouTube page I'm on perfectly.... I change back to the my headphones. Plays fine, I select spark again from sound outputs nothing not a sound. No matter what I do.. Uninstall and reinstall it works again but the second I turn off the amp or try to open a daw software or swap to a different sound output it just won't play a sound again until I uninstall and reinstall it making the use of a daw / presonus impossible



  • I'm wondering if this is a driver issue or remembering from a previous post I read a while back related to the i7 processor? Is there a way to use an alternative driver like asio for all for testing?



  • @soup Unless it's a specific iteration of i7 -- my system is an i7 (i7-10710U), and works with PG's native driver.

    Although in general, I actually use ASIO4ALL. I have PG's native driver mainly as a backup and for testing various things (same with PreSonus), but I really use ASIO4ALL for most things, which is actually cleaner if you have multiple devices, since it acts as a "meta" device to put in the DAW settings, and automatically redirects things to whichever device you have plugged-in when the DAW is started. It also doesn't restrict the sample rate to 48K, so you don't get an error in Studio One if the song setup is using 44.1K. You can also have different buffer sizes for different programs, since it loads on a per-program basis.

    It does involve a bit of learning and setup (it generally doesn't "just work" by default), but it is well worth the effort in the long run. It's a user-level program that runs and shows-up in the system tray every time you open a program configured to use its meta device, and subsequently loads an applicable lower-level driver (typically the Microsoft one, from what I can tell).



  • fixed it. Click here for a demo YouTube clip

    Turns out it was the positive grid spark driver causing the problem,
    I did a proper Windows removal of the driver and just installed asio for all, a little bit of setting up but it now works brilliantly!

    This little spark doubles up great as a stereo monitor speaker for presonus for bedroom recording..

    Still have a little latency that I never have with my audio interface but I'm sure with a bit more messing around I can loose it.

    Thank you so much for your help with this



  • @soup That's great! With ASIO4ALL, the default buffer sample size is 512, but you should be able to lower the buffer sample size, on a per-program basis. I think Studio One's buffer setting gets overridden by the driver's setting, so set it in the little ASIO4ALL app, not Studio One.

    With the sample rate at 44.1K, I generally have ASIO4ALL working without any static/clicking with the buffer size lowered to 128 for standalone apps like BIAS-FX and S-GEAR. Although for plugins within a DAW, 128 sometimes has some static/clicking with higher-gain presets, so for my system, it usually needs to be 256 for DAWs. But at either 128 or 256, there is no noticeable latency. One nice thing is that ASIO4ALL runs per-program, and so it can automatically set different buffer sizes for different programs like this.



  • @blueingreen said in Records fine but no audio output from presonus studio:

    @soup That's great! With ASIO4ALL, the default buffer sample size is 512, but you should be able to lower the buffer sample size, on a per-program basis. I think Studio One's buffer setting gets overridden by the driver's setting, so set it in the little ASIO4ALL app, not Studio One.

    With the sample rate at 44.1K, I generally have ASIO4ALL working without any static/clicking with the buffer size lowered to 128 for standalone apps like BIAS-FX and S-GEAR. Although for plugins within a DAW, 128 sometimes has some static/clicking with higher-gain presets, so for my system, it usually needs to be 256 for DAWs. But at either 128 or 256, there is no noticeable latency. One nice thing is that ASIO4ALL runs per-program, and so it can automatically set different buffer sizes for different programs like this.

    @blueingreen I can't thank you enough.. Will have a sit down later and try these settings,,
    Your a legend. Thanks for your help it's much appreciated