Problems Using New Download Page



  • It looks like I have completed the migration to the new website successfully. I can see all of my products, but when I try to select the OS from the dropdown, nothing happens. I've contacted support directly and have been emailing them back and forth all week, but they say that they can't duplicate it on their end.

    Anybody else having problems downloading their purchased products like me?


  • A2

    Try using a different browser...i'm on Firefox and no problem



  • Yeah, as I thought, the browser warning about IE/Edge incompatibility with the store means I can't log in without re-setting password, but then won't allow me to the store anyways. I had to use Firefox (which I may end up moving to, and have a cultured version for that possibility....) to really log in.

    Migrate is a weird thing as a user, though it makes sense given their apparent security scheme across the board.



  • I've used Chrome and Firefox on four different computers (all Windows 10).

    I've disabled adblock.

    I've used incognito/private.

    I've refreshed Firefox.

    I've cleared caches.

    I've reinstalled browsers.

    I've completely stripped browsers off (i.e. uninstall, registry, appdata, etc.) and reinstalled.

    I've created a new Positive Grid account and had support transfer my licenses over.

    I've tried from my Android phone.

    No dice.

    Yesterday, I had one Firefox session after refreshing the browser that managed to allow me to use the dropdowns properly. Then I closed and restarted the browser and I was right back to no dice. I haven't been able to repeat it since.

    I may try to setup a Raspberry Pi today out of desperation to see if Linux makes it any better.



  • Exact same issue here. Tried other browsers, works on a mac not windows 10. Downloaded the msi file on the mac and transferred to windows and they don't run. Did I just waste $149.00?



  • Found these links for the direct download to Bias 2 PC if it helps

    https://dlcf.positivegrid.com/BIAS_AMP2_Windows64bit_v2_0_0_615.msi

    https://dlcf.positivegrid.com/BIAS_AMP2_Windows32bit_v2_0_0_615.msi

    I'm on osx so don't know if I can help on the browser front, but I hope the links allow you to download it



  • Yes! Thank you Liam! I will try that same pattern to see if I can get the latest FX...



  • @michael-marsh no problem, glad it helped :)



  • Raspberry Pi 3 and Chromium works. Repeatably.

    Since Chromium is, basically, Chrome lite, I don't think it's a browser issue.



  • Looks like the download page is changed and works for me now.


Log in to reply
 

Looks like your connection to Positive Grid Community Forum was lost, please wait while we try to reconnect.