Spark amp app does not run on android 5.1.1



  • Google play store does not list a spark amp app on my android 5.1.1
    Manual installation gives error: device not compatible.

    This does not conform to the pre-sales information, where compatibility to android is suggested..

    What android phones work reliably ?



  • i think android 5 is pretty outdated ..just saying ..i had to get a tablet android 9.
    still waiting on the Spark but also waiting for them to get the App fully functional and work out the bugs people are experiencing