Bias Amp 2 Crashes on Startup MacOS Catalina



  • The title describes my issue. I have searched the forum and only found the "solution" that Positive Grid support sent me, and that doesn't work. I am trying to use the standalone version on my Mac Mini with an Apogee One interface. Bias Amp worked fine with older system installations and Bias FX2 works fine for me with MacOS Catalina.

    Bias Amp2 crashes every time the program is started. Support sent a link to a FAQ page that says to uninstall the program and delete the Bias Amp2 folder in Documents as well as a .settings file in ~/Library. There is no .settings file for Bias Amp2 in the ~/Library, only one for Bias FX2. Uninstalling and installing the program has no effect. when Bias Amp2 is starts it momentarily flashes a dialog box that asks whether it should check for updates, then crashes before any input can be given.

    I suspect there is some relationship to the fact that no .settings file is found in ~/Library and none is created on installation or startup, but I don't really know. I have gotten no further input from support. I suppose I could just give up, but it seems it should be possible to get it to run. Any help is appreciated.



  • @peteg I need to ask - did you enable the ability to "view hidden folders" first? the "Library" folder the settings file is in is a hidden folder and this is the only reason I ask (I assume you did since you say you found 1 .settings file and not 2 files - but still need to make sure) I have looked at an old backup drive and see the 2 files that should be there.

    Also did you after enabling view hidden use search for BIAS_Amp2.settings ?

    try it if not also there is a com.positivegrid.BiasAmp2.plist file you can search and destroy - good luck
    0_1586382878333_Screen Shot 2020-04-08 at 2.53.11 PM.png
    here is a picture of the path to the PositiveGrid folder location buried inside of the Hidden Users Library folder (which has another application support folder you want get into)



  • Yes I enabled hidden files and folders using the Cmd-Shift-. function. And yes there is only ONE file in that folder, "BIAS_FX2.settings". The file associated with Bias Amp2 is missing. This is true after a fresh install, and attempting to run the program does not create this file prior to crashing. Actually, I have no idea if the installer or program should create the initial file, but neither do. Also, FYI the folder and FX2.settings file are visible whether or not viewing hidden files is enabled. Thanks for helping.



  • @peteg FYI the User "Library" folder is absolutely not visible this is a hidden system folder - the picture shows this as a "grayed out" folder - I don't make the rules on that folder Crapple does - I never said any other folders or files were hidden read again

    cheers



  • You are correct regarding visibility. I access the library by using Finder-Go to Folder-~/Library. Once you do that, the contents of ~/Library are visible regardless of the "Show hidden files..." setting. Any ideas about the crashing on startup or missing settings file?



  • @peteg so I just ran an older installer of BIAS_AMP_2_Mac_v2_2_8_1409 and I can now answer a couple more things:

    1. the PositiveGrid folder in the application support folder in question is not created during the install - it is instantly created on open of the application (Bias Amp 2) the first time

    2. the folder is empty until you close Bias Amp 2 the first time and then it instantly writes the .settings file in question

    • but for your issue "not being able to run the app after the install" this is a real issue if it is indeed happening as such. The support suggestion to manually clean up then re-install is the first trick. Try rebooting too of course, not that you don't know. If there is no solution reach out on your support ticket again and ask for more help, you can always report any findings back here.

    I am also using Catalina 10.15.4 I am able to install and run the version I have listed above



  • Thanks for your debugging help. I have installed 2.2.9.1438 on MacOS 10.15.4. I did report back to Support that the recommended solution had no effect, but never heard back. That's why I thought I'd try the forum before giving up. These are challenging times, so I really don't have any issue with response speed. I have other amp simulators on my Mac, so maybe there is some sort of interference issue.



  • Soooo... Absolutely no idea why, but Bias Amp2 started working today. Support asked me to uninstall the program, delete some files and reinstall. I did so, and the program still crashed repetitively. Today I tried to start the program again and it miraculously started and ran. No idea why, The only think I did was clean out some unrelated files on Dropbox, not even on the computer itself. Oh well, guess I'll buy a lottery ticket.