IR impulse response files - filenames max 20 charakters?



  • Not that I know of, you can do it the old fashioned way, by placing the various amp folders (if you have them like that) in the presets folder for BIAS Fx, and then enter the relevant entries in the 'bank.json' file, you'll see the format and what is required by looking through the file.

    Importing into Amp1/2 they will show up in FX, then you can just save them.


  • A2

    Jeez Louise....WHat about exporting a bank of Bias Amps in Bias Amp? Like you said, these definitely need to be renamed, but I want to make sure my projects all know whos who, whether I'm on my home or work computer



  • I just had a look, it seems that for Amp1/2, the old method doesn't work for them any longer because the file you would have to edit seems to have changed, and is not human readable (it still is in FX) if you could read the 'cate.idx' file it might be different, but I don't know how, then it would be just a matter of finding the correct folder (which can be done with a little effort, you soon work out how to close in on it) but because they name the folders with such meaningless names like '3AA7F820-F048-8818-CB12-60AA1AAFB743' it makes things a bit difficult, but it is possible, and not quite as hard as it may sound when you get the drift lol :) and then adding the relevant entries, all a bit painful though. If they had a decent and consistent method of preset management among all the BIAS's it would make life so much better, but alas.


  • A2

    Man, they really really need to deal with this...Luckily it seems like if I open a project at home, it usually loads the amps ok, but man, I would love to not make everything twice



  • There is much pain to be had with the PG family :) if they weren't as good as they are/can be, myself I wouldn't bother. Imagine my pain at doing it for 1800+, it literally took me a couple of weeks, anywhere from 3 to 5 hours a day to get it done so everything would be a breeze from then on, talk about going into zombie mode, if I somehow lost my backups, I would drop BIAS family immediately, because there is no way in hell I would go through that again.

    If I or they can't sort out the issue stopping me from updating BIAS FX Pro in the not to distant future I might just right it all off and move on all things considered. I'd really like to see if what they have done with the new DSP makes the pitch shifting/Octaving etc better than it was, well . . . it couldn't be worse, it was pretty bad, but they say in the release notes it was a 'Major' updating, but I'm stuck 3 versions back.



  • If it is just getting the same thing on 2 or more different computers you are looking for, that is quite easy, you just copy the presets folders and preset files from the one you have set up and place them on the other computers, I would first backup, or rename what you are replacing to OLD or Original or something just in case, but I have never had an issue with it.



  • I could supply you with the folders with amps already renamed for whatever pack you have, of course they would be how I renamed them, something like 'DR 3C v1-1' etc etc for the Mesa Boogie Dual Rectifier 3 Channel amp for example,
    that you could just drop in your preset folder and they would show up renamed and easily identifiable from within BIAS FX (and better in Amp), to be safe you could just backup your preset folder just in case, but I've never had a problem.


  • A2

    For Bias FX where are the preset files and folders exactly? I see the ones in documents/biasfx

    Do I just copy the whole folder and its subfolders?
    It has Module Presets and Presets folders and then the license, .pgbiasfx and midi.json files



  • Documents - BIAS FX - Presets

    No not the ModulePresets, it's all in the above.


  • A2

    Thank you!



  • 'bank.json' is the file, open it and have a look if you want to familiarize yourself with the format, pretty simple, but just copy that file, and all the folders, you can leave out factory 1, 2 and 3 unless you've added to them or changed the factory stuff, and the folders
    6683CD2A-39D9-EEC0-6510-369203A24FFE
    B606D598-14C7-EB98-AC80-771F114935F
    are factory (may or may not be the same on your install, I think should be though, nothing much in there to worry about)


  • A2

    That's for Bias Amp right?


  • A2

    AWESOME!!!! COpying the presets folder worked perfect! Thank you



  • @pipelineaudio said in IR impulse response files - filenames max 20 charakters?:

    That's for Bias Amp right?

    FX, I thought that was what you asked above . . . "For Bias FX where are the preset files and folders exactly?" Sorry for any confusion.

    For BIAS Amp 1 the location is Documents - Bias - GlobalPresets, and the file is 'cate.idx' (as far as I can see not human readable) So you would copy the GlobalPresets folder and the cate.idx file. You can copy the whole Bias folder if you like.

    BIAS Amp 2 - the location is Documents - PositiveGrid - BIAS_Amp2 - GlobalPresets, Custom Presets go inside the folder with a lot of numbers and letters for it's name, the preset file is the cate.json inside the GlobalPresets folder, again you could copy the whole Global Presets folder, or indeed everything else inside BIAS_Amp2 folder, same goes for Amp 1, as long as the target instalation is the same version etc.

    It may work over different versions, but when I was investigating my BIAS FX Pro issue, I put files and folders in from version .3174 into the folder for the latest version, and when I fired it up I got a Windows installer type message, it ran as normal, but didn't cure my problem, the GUI still flaked out, was worth a shot, so I uninstalled and deleted any associated folders/files left by the uninstall, rebooted and installed .3174 again and back to normal, still 3 versions behind and unable to get a working update after that :(



  • @pipelineaudio said in IR impulse response files - filenames max 20 charakters?:

    AWESOME!!!! COpying the presets folder worked perfect! Thank you

    Cool, glad you got it sorted, I started to think we were getting our wires crossed :)


  • A2

    These sound pretty cool, but DRASTICALLY different between Bias Amp 1 and Bias Amp 2. The difference is right in line with the "wet blanket" effect of the BA2 cabs. I thought there was a fix for this, or someone had a trick to make it work, but I couldn't remember what thread that was.



  • Personally the only reason I use BIAS Amp1 Pro is to get the amps available in BIAS FX Pro, as everything becomes available in FX, that's what I use, and everything sounds better in BIAS FX IMO.

    I rarely even touch BIAS Amp2, I'm not very keen on it at all, don't think it sounds very good, and most of the cabs pretty much suck. I only brought the Pro version because I already owned all the Celestion cab's purchased separately, which I also don't think much of, they are OK, but I have others I much prefer to use, Rosen Digital/Lancaster Audio, Redwirez and Choptones namely. I would much prefer to use Amp1 than 2, but as I said I only really use Amp1/2 as a vehicle to get stuff to BIAS FX, because in my opinion BIAS FX sounds better, is better, has all the effects etc, etc, etc . . . . the same as I don't actually use BIAS Pedal Distortion, Delay or Modulation as such, only in the fact that it all shows up in BIAS FX Pro, and that's where I use them.

    To me, BIAS FX Pro is the final destination, where everything goes to be used, the other stuff is just to get stuff there, whether it's amps or pedals you have personally made or matched or whatever, but I never use them as the 'Final Player' as it were, for me everything is better and sounds better in BIAS FX :)
    Plus BIAS FX encompasses the whole shebang

    I have read about that 'Wet Blanket' thing when using BIAS Amp1 amps in Amp2, and the supposed cure, but can't recall where it was.


  • A2

    Me too, I load my impulses in Bias Amp and then do all the level matching in Bias FX. I'm having a bizzarre problem today in that I can't load impulses. The older heads I made before are still working fine, but adding even the same impulses to any new head just doesn't take. I did delete some of my folders yesterday then reinstalled Bias Amp 1, so maybe it messed something up, not sure.

    Loading impulses is looking like this now, instead of the pulsed wave

    alt text



  • There is a thread that links to a version of BIAS Amp (1) which is not available on the official website, and has a higher version number than the latest officially released version for BIAS Amp (1)by PG that fixes this issue I believe. Check out the following thread, link is provided by one of the PG dudes Mike (Mod)

    https://forum.positivegrid.com/topic/1894/impossible-to-load-any-irs-in-bias-amp-pro


  • A2

    Thanks, this worked!!!!

    Man after level matching all afternoon, I realized Bias FX does not save the output volume with the preset :(

    I did some null testing and found that the graphic EQ is transparent so you can use that as a master output volume knob

    Some of these choptones sound great but the levels are ridiculously all over the place and a lot of them are phasey as all hell, like they tried to use a matching EQ or something