Logic X settings for Bias Amp



  • Hi Shredders, I need genuine help: for some unknown reason I'm hearing a clean, unprocessed raw tone sitting underneath my chosen heavy amp tone, on the same track. Nothing else is activated on the Logic X track - only Bias Amp. I've tried both "Stereo" and "Dual mono" settings in Logic and it doesn't change. ("Mono" is not an option). I've tried centre, pan L+R and no change. It's still there. The direct guitar is being picked up but I have no idea how to mute/ deactivate it. The guitar only comes through on the left side and there is "Mid-Side-Couple" setting on top on Bias Amp. I need to change this to mid in order to hear the guitars on centred. This has to do something!!

    Help please as my bandmates are getting the shits with me :) LOL



  • @dejan-toracki I don't know if this will cure your problem but here's a link to another thread in this forum where I posted a picture based tutorial on how I setup Bias Amp in Logic Pro X. May need to wait for the pictures to load depending on your internet speed. Second post from the top. Hope it helps

    Link to tutorial here



  • @anthony-newcomb legend! Thank you I will go through it with interest! Much appreciate it



  • @dejan-toracki-0 I think you solved it!! It was simply the ability to switch to mono via the "circles icon" in the track set up. Legend status remains!!



  • @dejan-toracki Glad to hear you got it working! I'm no legend lol...but I'm glad I could help