Tablet: Fire 10 Gen 7 - Can't Install Spark App thru Google Play Store



  • I installed Google Play Store on my Amazon Fire HD 10 Gen 7 tablet. Installed ok. I installed the Positive Grid AccuTuner from the Play Store, no problem. When I try to download and install the PG Spark Amp App, it gives me the message "This item is not compatible with your device". I've read others have installed Spark on the Fire Gen 10. Am I out of luck with installing Spark on the Fire Gen 7? Thanks.



  • @wtnadal Got my answer, Spark app on Amazon Fire devices is only supported on Gen-8 models and later.



  • @wtnadal
    Is the issue the processor, or the Fire OS? Anyone tried replacing FireOS with a more generic Android OS to see if it will install/run the Spark app?



  • @enginears
    Amazon make it non trivial to root their devices. From what I can gather, yes you can root it and replace with an android nougat (7.1) build. To do it though you need a linux machine to interface with the tablet for the process.

    That should technically run spark software. 7th Gens did receive an updated middle of last year but only to a version of their own o/s based on android 6.

    PG have just depracated this o/s as part of the install check process. I doubt the pg app needs much processing power to run. Its essentially just a moderately pretty gui to send a few controls to the amp or run an instance of youtube.



  • Thanks, that's pretty much what I thought. I attempted to root my spare Fire HD 10 7th gen and replace the old OS with 7.1, but somehow I ended up bricking the device. Forutnatley I was able to recover and set it back to stock. As luck would have it, got a killer deal on a 9th gen Fire HD 10 so now I am happily running the Spark app on that.



  • Have you tried googling PG Spark apk?