Spark APP not learning song



  • I just got my Spark and its really an amazing practice tool. One issue I am having is that when I search a song say on YouTube, it comes up and the app says its learning the cords and will be ready shortly. It automatically starts to play the song in real-time and the progress bar goes up to about 85% and then just stops. The song will finish playing but nothing else happens. It never shows the chord chart and anything else. It gets "stuck". I have tried it several times to no avail. I rebooted the app a few times and the same issue.

    Its really too bad because if this feature worked well and consistently this would be the most amazing way to learn new tunes quickly. Anyone else has this issue and found a fix?

    Thanks in advance



  • What is the app on? I found it wouldn’t work on my iPad but works great on my Android phone.



  • I am using it on my ipad. I have an iphone but not an Android



  • Ive had the amp about 3 weeks - and I just noticed the exact same thing but it only started 2 days ago - i thiught maybe i was feeding it some tough songs, but now I think they’ve tweaked something in the cloud (the algorithm must live there, because when PG had a server hiccup 2 weeks ago, the chord learn function stopped working).

    ive submitted a trouble ticket to PG using the button at the top of the forum



  • ok, maybe that is it. I tried feeding it several songs. Simple 3 chord songs and the same thing happens. I also noticed that when using the song learn function it takes a while to connect to their server and may time I get a "time out" message. However, the rest of the app works fine so it's not my network or internet connection. I really wish you could simply hook up the spark to a computer and use a desktop app instead. That would take the "wireless" piece out fo the equation



  • The other thing I noticed is that even if the song finishes playing and Spark learns the chords, it will list them in the bottom left corner of the screen under the song name. However, it does not show the chart of the song structure so you can loop sections, slow down sections etc..

    for me, this is the one feature that made me really want a SPARK and now that does not work. Hopefully, they fix this quickly or I may just sell the amp. Maybe other company will come up with a similar amp that actually works consistently.



  • my app works fine on two different Android fones.
    must be a bug in yours.
    id first try the normal app fixes like, clear cache, force close and maybe re installing it.
    By the way, the song chords are not synced 100 %
    and the looper is not seamless and you can only edit by block by block, which aren't synced to the downbeat.
    So as long as you can use the amp part of the app, you're not missing much.



  • I am going to try this on a Samsung Galaxy tablet today to see if that works any better than the i-pad.



  • Yes, all the time. About 1 in 4 loads correctly. Using iPad.



  • I've noticed this lately. It's as if the internet connection is weak and it just won't load. I have a couple of newer downloads that worked initially but now won't load at all.



  • Yea, I tried a Samsung Galaxy tablet and I could not even get the amp to connect to it so I sent that tablet back. Now I am back to using the ipad again.

    To make sure I had a perfect internet connection I purchased an i-pad adapter that allows using an ethernet cable to connect to my network so you are not relying on the wi-fi. Now I know the internet connection is solid and I still have the same issue. I can try to have the app learn any 3 chord song and it starts the analysis process and gets to about 85% finished and just stops. The song will play all the way through but no chord chart or anything else. It simply gets hung up.

    I am really disappointed with this as this was the main reason I purchased the Spark amp. Like everyone else, had to wait for months to get it, and now the main feature for me buying the amp in the first place does not work. Oh well, maybe PG will get this fixed if enough people send their support a request.



  • UPDATE - I sent a short video to the tech support per their request and here is their response below

    ***Hi David,

    Apologies for the inconvenience. Our tech team is aware of this bug and will be releasing a fix/update sometime later this week or early next week. Please make sure you update to the latest version once it is out. You can do so from the Apple App store/Google Play store on your device.
    Feel free to shoot an email back if you have any further queries.***



  • @info-a They released the update, I updated, now I no longer have a list of Liked Tracks and the recently played list isn't available until you play something from the music page or a download. They are going to fix this thing until it doesn't work at all.



  • thanks for the info. Does the song learning function now work at least?



  • I just checked and they have not released the update for the iPad The current version is 1.60 and that the same version that I am having issues with.



  • @info-a no better than before.



  • I have IPad Spark software version 1.6.0.2836 and the song learning function is working for me again



  • I have the same version and its not working. 1.6.0.2836



  • I spoke too soon. I thought it was working again because the song I sent to PG as a sample is now showing up with the chords. But when I tried another song, it hung up like before. I guess PG must have run my sample song through their algorithm locally, so now its part of the library.