BIAS FX 2 - Beta

  • administrators

    Dear BIAS FX 2 community,

    I'm excited to let you guys know about the latest BIAS FX 2 2.2.0 beta, which includes plenty bug fixes and lots of improvements overall! Please find the link below for download.

    BIAS FX 2 - Beta

    Release Notes:

    • Shortened waiting time when opening amp menu
    • Improved efficiency for drag & drop, undo/redo behavior in the signal path
    • Improved efficiency for Windows installer
    • Support 64-bit VST3 plugin
    • Display issue under High DPI mode in Studio One fixed
    • Various other performance improvements

    Any feedback is welcomed! Cheers :)

  • @dans-huang

    I tried it in a few DAWs on Windows 10, and VST3 worked fine in 3 out of 4:

    • MOTU Performer Lite 10: VST3 fails examination step; VST2 works.
    • Ableton Live Lite 10: VST3 works.
    • Studio One Artist 5: VST3 works, and window display quirk is gone.
    • Reaper 6: VST3 works, and window display quirk is gone.

    Also have MOTU Performer Lite and Ableton Live Lite on MacOS, with the same VST3 results as above.

    MOTU's Performer Lite didn't like the VST3 ("examination" step says it has "serious problems and will not be loaded"). I got the same thing on both Windows 10 and an older MacOS system still on High Sierra. On Windows, VST2 still works, and on MacOS, AU still works. I didn't actually try VST2 on MacOS, since I generally only use AU there, but it did pass the "examination" step.

    One thing on MacOS -- using "Responsive" window size caused odd behavior in the plugin (at least in Ableton Live Lite), such as freezing behavior, and I couldn't get the "Settings" drop-down to go away. So, I had to delete the plugin from the track altogether and re-create it with the "Standard" window size. Did it a few times, to make sure it wasn't a one-time fluke.

    EDIT: While testing, one small thing that I thought would be nice to add to the "App information" area is which type of plugin you are actually running. For instance, under "App information", it tells you the plugin's version and whether 64bit, but it would also be nice to have it verify if you are running VST3 vs. VST2 vs. AU, since in some DAWs, it isn't always clear. Sometimes they just list multiple instances of the plugin with the same name, without indicating which is which. So, it would be nice to verify the plugin type under "App information" if this could be added. Thanks!

  • The BiasFx plugin (VST3) still cause Ableton Live 10 (Standard) issues when closing / switching or closing the project!

    If I use the BiasFx Plugin and quit without saving .... Ableton cannot delete the undo folder!

    video - issue

  • administrators

    @blueingreen Thanks a lot for the feedback. Unfortunately we do not officially support MOTU Performer Lite but would you please send us a support ticket for further follow up? Thank you!

  • administrators

  • @dans-huang I already did that before (open a ticket) and the link you suggest is just a instruction how to delete the folder manual and not a solution. I also made a video to show that the plugin somehow blocks the Ableton "Undo" folder. It's clearly a permission issue between Ableton and Bias FX on Windows 10!

    Ableton with Bias FX
    Ableton without

  • MIDI Program Change. It doesn't seem to work . VST3 version, Reaper 6.12, Windows 10.

  • After the update, all of my DAW tracks, guitar and bass, defaulted to American Dream (DAW is Studio One Professional). For example, before the Bias update my bass track was using the factory preset of Bass > Killer Bass. After the patch, the Bias FX2 preset for the track is American Dream and not Bass > Killer Bass. This occurred for all of my guitar and bass tracks in all of my songs using Bias FX2. I had multiple guitar tracks (approximately 4 to 6 tracks) using different Bias FX2 presets.

    I’m still trying to locate files on my system (Windows 10 Pro) that would have caused this. The folder I did manually revert back was under C:\Users<computer name\Documents\PositiveGrid, but this didn’t fix the issue. I don’t recall what Factory and/or User presents I used on these tracks, this applies to all songs I’ve recorded so far. Think of it as having one of the colors in Monet’s paintings reset to basic blue.

    I have a ticket with support, but no progress.

  • @siberino I have the same issue in .5050 when using the VST3 version. submitted a ticket and was told there is no work around right now, so I am going back to the VST2 version which seems to be AOK.


  • @paul-jones32 Support (Dans) did get back to me and the fix is, "Please uninstall the program altogether and reinstall the previous version to see if the issue resolves" Support provided the -reinstall for version, which I'm still on. I'm not sure when it's safe to upgrade to the latest version.

  • @paul-jones32 Thank you! =)

  • BIAS fx in IOS 14!!!!