Recording issues in DAW



  • Just got my spark everything works and sounds great. I use Acid Music for my DAW and laid a basic drum track, plugged in the spark and attempted to lay a guitar track. I got it to record but I am experiencing 2 issues - 1) Really Low playback level on the guitar. I have the Master and Output really high, and the track recording level at max. 2) Latency issues. On playback the guitar track is not synced with the drum tracks.

    I only had 2 driver options, none were ASIO they were just the generic windows drivers.

    If anyone has any advice on some things I could try would be apprecaited.



  • If you just got yours, then it probably already have this version, but just to check, do you have the latest firmware version (1.2.3.37)? I noticed that increasing USB recording volume was one of the things fixed:
    https://help.positivegrid.com/hc/en-us/articles/360044432072-Spark-Firmware-Release-Notes

    Generally, ASIO is the only reliable way to go, especially with latency. Does the Spark's native ASIO driver not install?
    https://help.positivegrid.com/hc/en-us/articles/360039598451-Spark-Windows-ASIO-Driver-

    I actually use the ASIO4ALL driver, which I think works better, plus it works across my multiple audio devices, rather than installing a bunch of separate drivers for each device. It usually doesn't "just work" out-of-the-box, and you have to learn to tweak a few things, but you learn it once, then apply it to all devices:
    http://www.asio4all.org/



  • @blueingreen Ok thank you for the help, I will check both of these out. No driver or anything installed or showed up when I plugged in the spark into my PC. Should my computer have recognized it somehow and installed a driver?



  • @sjdonahue13 Windows 10 usually does that automatically -- not sure on older versions. But may not be the same as Positive Grid's version on their site.



  • @blueingreen Yes I have Win10 and I thought it was strange it didn't do anything when i plugged it in. I'll check this out and appreciate the help!



  • Using the USB interface into a Mac, I'm getting a noticeable latency on output/monitoring when recording into Garageband. I'm on 1.2.3.37 firmware. Is this expected behavior?



  • @jimjimk I don't have a Mac but in my research watching youtube vids etc. I am pretty sure they suggested turning the monitoring off on your mac to avoid this. Not 100% sure but worth a shot.



  • @jimjimk said in Recording issues in DAW:

    Using the USB interface into a Mac, I'm getting a noticeable latency on output/monitoring when recording into Garageband. I'm on 1.2.3.37 firmware. Is this expected behavior?

    Same here. :-(
    Not only, but the volume through the headphones is so fu**ing high it blows my eardrums, whatever the settings of the amp. :-(
    And the signal volume from the Spark is ridicolously low, whatever the settings on the amp side AND the recording level set on max.



  • @sjdonahue13 I record to my iPad and have found that turning off the monitoring helps with the latency as long as my headphones are plugged into the spark. If you’re listening off your Mac either with monitors or headphones then you’ll need the monitoring turned on.



  • @drbaroni Ditto. Frustrating AF.



  • Don't know much about Acid, but you're going to have latency with any program. Look up how to adjust it. Any DAW that doesn't have latency correcting isn't worth using. Audacity is really easy to correct, I'm sure others should be as well.



  • If you have the Spark connected via USB and you are listening with headphones connected to the Spark (not your computer), then the Spark's controls work like this:

    • The "Output" knob controls the local "pre-production" volume (pre-computer/DAW), essentially acting as a local monitor volume. Since this output is local to the Spark, there shouldn't be any latency issues. You should be able to adjust this to a comfortable speaker/headphone volume without affecting the DAW's recorded volume.
    • The "Master" knob actually determines the volume level sent to the computer/DAW, similar to the input gain level controls on audio devices like PreSonus/Focusrite.
    • The "Music Volume" knob controls the final "post-production" volume, after the sound returns from your computer/DAW, back to the Spark. If you have a media player also playing music or other instrument tracks monitored within the DAW, then these will all be controlled by this knob. If you are also monitoring the guitar track, then this output is more susceptible to latency than local "Output".

    Note that if you are using the Spark to do all your guitar effects, then there's no need to have monitoring turned on for the guitar within the DAW, which is largely redundant, more susceptible to latency, and also could be contributing to extra volume due to redundancy if you are also using the "Output" knob.

    You only need to be monitoring in one place -- preferably, it should be locally on the Spark itself using the "Output" knob, with the "Music Volume" knob turned down. If you do need to use DAW monitoring, then the volume is instead controlled with the "Music Volume" knob, with the "Output" knob turned down.

    EDIT: Also, if on Windows and your DAW recording level is still low (even after raising the input level with the Spark's "Master" knob), one other thing to check is your Windows input device volume. On Windows 10, right-click on the volume control on the task bar, then choose "Open Sound Settings", then under the "Input" section, make sure that the Spark is selected and click on the "Device Properties" link underneath, and then make sure that the Volume is set to 100% (or at least 90%). This device setting can sometimes undermine everything else in the chain.



  • @7453dennis2j said in Recording issues in DAW:

    @drbaroni Ditto. Frustrating AF.

    Ok, the volume in the headphones is now manageable, via the little "Music Volume" knob. I'd believe it's changed with the firmware update, but I'm not sure, it's likely me being inept. :-D
    The signal volume from the USB is STILL ridicolously low. I made a comparison yesterday night, recording an overdub via the ZOOM G5n, and the signal was perfect, right at zero db and not at - 40db even with rec level at max. Also, I can't find a way to "normalize" the single tracks in GarageBand, so if anyone knows how to do that please tell me. :-)



  • @drbaroni Interestingly, they supposedly increased the USB recording volume in the previous firmware update in June:

    Increased USB recording volume (for units shipped with firmware version 0.1.2.197)

    https://help.positivegrid.com/hc/en-us/articles/360044432072-Spark-Firmware-Release-Notes

    I mainly use my newer Windows 10 system nowadays, but I just looked at my older 2011 MacBook Air, and noticed that for some reason, the Spark is slightly different in the MacOS Sound settings. With my PreSonus AudioBox device, if I go into the MacOS Sound settings, both the Output and Input show "The selected device has no output/input controls". Up until now, I assumed that the Spark was the same.

    But I just now looked at it, and for the Spark, it says this for Output, but not for Input. The Input actually has a slider control, just like the builtin "Internal Microphone". Mine was already set pretty high (nearly 100%), but you may want to check that this OS-level setting isn't set too low, which is similar to my previous post regarding the Windows device settings undermining the chain.

    I've never actually used GarageBand, despite its sitting on this computer for nearly a decade, since I've used Reaper and Ableton Live Lite on here. I just tried opening it for the first time ever on this computer, and it's GarageBand '11 (as in 2011), in which I'm going to go out on a limb and guess it isn't the latest version...



  • @blueingreen

    Thank you for the tip. I checked it again, and... the input for the Spark HAS the slider control. And it's already all the way up to the maximum. :-(
    So I really think there's something wrong with some other setting. Maybe it's my tones' "volume" that's too low? But then how comes that with the same kisd of output levels on BOTH my pedalboards the sound is perfect, sometimes even clipping?



  • @drbaroni Out of curiosity, I installed the latest GarageBand on my Mac, which I was frankly surprised actually updated, since more and more Apple stuff doesn't support my older system, which is still on High Sierra (can't upgrade beyond that).

    I didn't do anything special, and have never used GarageBand before, so maybe it is beginner's luck, but it seemed to work, even on my older 2011 system. I basically created a generic "Audio Track" (NOT a guitar-specific track , since that is redundant), then unchecked the settings for both "Master Echo" and "Master Reverb", and left the "Record Level" slider at its default. To test the DAWs volume (as opposed to the Spark's local volume), I did the following:

    • Set the Spark's preset to the factory hardware preset #4, which is the default "4-Metal" one.
    • Set the Spark's "Output" knob to zero to turn-off its local monitoring.
    • Set the Spark's tiny "Music Volume" knob to about 10:30 to enable monitoring via computer/DAW output. I'm using headphones, BTW.
    • Did not touch the "Master" knob, so this is simply using the preset's default input volume, although this can be adjusted to change the input volume to the computer/DAW.

    I then hit the "Input Monitoring" button on the track in GarageBand, and commenced playing, and the volume was perfectly normal to me. I then hit the record button, played a bit more, then stopped recording and played it back, and the volume was also perfectly normal to me. Again, maybe beginner's luck, but I didn't do anything special.

    On another note, I was just thinking this week that I should remove Studio One Artist from my Mac, since it's silly to maintain three DAWs. I got Studio One Artist and Ableton Live Lite licenses included with my PreSonus AudioBox purchase, and I bought a non-commercial license for Reaper awhile back. Ableton Live Lite and Reaper are still fairly snappy on my older Mac, but Studio One is more sluggish, which is why I really only use the other two (even on my newer Windows system). Now, I still haven't removed Studio One, and I just installed and setup the latest GarageBand, so now I have four DAWs installed and am going in the wrong direction! But in all seriousness, GarageBand is actually kind of nice, and I think I'll keep it on there.

    EDIT: Forgot that I did actually disable a couple default track settings.



  • @blueingreen

    That's interesting. :-)
    Maybe it is the fact that I use pretty much ONLY clean, low gain tones. It still doesn't explain why with my other two devices (pedalboards) I don't have that problem and the volume is as high as it shoulds, even saturating the track sometimes. :-)
    I'll try it your way and will let you know what happens. Thanks again. :-)



  • @drbaroni I generally only use medium-gain or clean"-ish" tones. I don't actually do metal, but just figured that it would be more obvious if it didn't work, and wanted to use a stock preset that could be easily duplicated. But in general, it seemed like the same volume as anything else I play. In any case, if turning-up the "Master" knob on the Spark doesn't help, then I'm not really sure what else to try. Are you running firmware 1.2.3.37?

    I did encounter some oddness -- a couple times, there was suddenly extreme delay or latency while playing (like over five seconds). Each time, I exited and restarted GarageBand to get it back to normal. Never encountered that with any other DAW, so I don't know if there are just quirks between the Spark and GarageBand.



  • @blueingreen
    Hmmm. I'm starting to think that there are quirks between the Spark and Mac OSX 10.15.6 Catalina... :-D
    I just recorded an overdub track on a friend's song. Did it on GarageBand, with the Spark and with the ZOOM G5n. The difference is huge. With the Spark I had to LOWER the song's level by half the slide run and set the recording level to the maximum, and even so it's still low (I had to pluck the strings pretty hard to get an audible sound). Then I tried with the ZOOM G5n and I had to put the level of the song back to 0 db and lower the recording level, and I played very softly. THere must be something wrong in the settings. I dont want to get a high volume in the headphones. :-)
    And as you named it... Yes, latency is another problem that I do NOT have with neither of the pedalboards, but that is there with the Spark. :-)

    PS: just tried setting volume and master up to the max. Signal via USB doesn't change. :-(



  • @drbaroni My latency issue seemed more like a bug. Generally, there would be no latency, then all of a sudden, it would go from no latency to over five full seconds. I'd exit GarageBand and re-open it and everything would be back to normal.

    In any case, a few misc things I came across:

    • After trying lower-gain presets, I did in fact find the DAW monitoring to be lower-volume than other audio devices, but the actual recorded volume was generally the same level as anything I recorded with my PreSonus AudioBox, so long as GarageBand's "Record Level" was at 100%.
    • GarageBand's "Record Level" and the MacOS Input Sound level slider mentioned before are actually one-in-the-same. If you change one, it changes the other.
    • The other DAWs seem to automatically force this Input level to 100% when opened, but GarageBand does not.
    • So, GarageBand's "Record Level" seems like it needs to be at 100% to record and monitor at the same volume as all the other DAWs I'm using (with track volumes all at default 0dB), and so it seems like 100% is its "normal" state, unless you need to trim volume.

    I seem to be OK with recording level, and as for the DAW monitoring level 's being low -- I monitor at the Spark level anyway, so the DAW monitoring was more just exploration anyway. In any case, the last firmware release was June 12th, so maybe the next one isn't too far away!