Something went wrong during the maintenance. Some of the profile icons might be missing. Please re-upload your profile icons if this is the case. Sorry for the inconvenience.

Wondering if some things are improved in BIAS AMP 2.



  • The two main issues with BIAS AMP 1 I've run into are as follows:

    1. The VST window takes ages to load when I need to make an adjustment to a track. Sometimes more than 10 seconds while running on a pretty beastly computer (i5 7600, Intel NVME SSD, 16G RAM).

    2. There is no 'undo' functionality that I can find. Turned that slider and forgot what the previous setting was? Tough luck.

    Has anyone run into these issues with version 1? If so, are they fixed in version 2?



  • I know both and both are unchanged in v2.
    But your first point appears only once , on every first load of the VST instance. Could be because of the GUI, because EZ Drummer takes a lot of time too.



  • @sascha-ballweg said in Wondering if some things are improved in BIAS AMP 2.:

    I know both and both are unchanged in v2.
    But your first point appears only once , on every first load of the VST instance. Could be because of the GUI, because EZ Drummer takes a lot of time too.

    Thanks for the info. You're right in that subsequent loads of the same instance are faster, but I have so many guitar tracks in my projects that the load time really adds up for each instance.



  • Sascha is right on both. Neither have changed, but both have been reported to Support. You can report as well via Support ticket.