Does the Spark App connect to your Spark AMP using an iPad Air?



  • I have an iPad Air and after upgrading the firmware on my Spark AMP I cannot get the Spark App to connect with the Spark AMP. It can connect via Bluetooth to play music through the Spark AMP (ie use the Spark AMP as a Bluetooth speaker) but will not connect through the Spark App.
    If you have an iPad Air and it's connected I would like to know what you did to get it to connect (ie in the settings).



  • @peter-1 I have an iPad Air and I hope this problem does not stay an issue, I was counting on this working and I am not about to give Apple another $1000 for another iPad.



  • Hi Doug. I'm sure there are loads of users out there who have no trouble with their iPad Air and their Spark App and AMP. Those are who I am trying to contact to see if they can tell me their experience and the settings they use. I don't think I'm alone though. PG should provide a 'roll back' option for any upgrades to the AMP or App.



  • @peter-1 I have an iPad Air Gen 3 and have not upgraded the firmware as mine has worked perfect from the beginning (no hum, no glitches, noise gate works well, etc.). As far as settings, in the iPad Bluetooth section there is the “Spark 40 BLE” that links the app to the Spark and there is the “Spark 40 Audio” for playing tunes from your iPad. All I remember doing when I first got the Spark in April was clicking the connect button for each in the Bluetooth setting screen of the iPad. I haven’t had to do anything else on the iPad, it works each time I turn on the Spark (just have to click the connect to Spark button on the app). Not sure if this helps you.



  • @bschultz8 Thanks. To a certain extent that gives me some idea. I don't get the "Spark 40 BLE" option in Bluetooth. I can only see the "Spark 40 Audio" which I can connect to via Bluetooth and it does play the music through the Spark AMP. Don't know though where the problem lies? iPad Air, Spark App, or Spark AMP?



  • Have you tried removing the Spark Amp from your device and re-adding it? If not, I would give that a shot.



  • @pdelarosa22 Thanks. I think I've tried almost everything now. Even wiping my iPad Air 1 and setting it back to factory settings! I spent over 2 hours on the phone with an Apple Engineer as we tried things. He even did a full diagnostic test of my iPad but found no problem.
    One thing that doesn't match is the procedure on the Positive Grid website ("How to Pair Spark Amp with Your iPhone/iPad via Bluetooth?") shows as the first step to go to Settings > Privacy> Bluetooth and enable Spark Amp app. I don't have that on my iPad Air. I have Settings->Bluetooth Data. But there is no Spark under the listed Apps. I think that this may be the problem. The Spark App maybe doesn't have the privacy permissions it needs. Maybe? I'm getting totally 'peed off' with it now!



  • @peter-1 Are you sure you have the Spark Amp app installed? I just read what the Apple Engineer suggested, and I went to Settings/Privacy/Bluetooth and there was my Spark Amp app listed, plain as day, with it already enabled. And I don't have the amp yet and thus haven't tried to connect through bluetooth.

    There's another place for you to look to see if things are set properly, if you really do have the Spark Amp app installed.

    1. Go to the Settings menu and make sure you're at the main Settings page, not in any of the sub-pages like Privacy or General.
    2. Scroll way down this Settings screen -- you'll see the main Apple iOS apps, but then at the bottom you should see a list of all the other apps you've installed on your iOS device.
    3. find the entry for Spark and tap on it. You should see a screen which shows a list of things: Bluetooth, Microphone, Media&AppleMusic, Siri&Search, Notifications, BackgroundAppRefresh. On my iPhone the ones which are enabled (the button shows green and the number 1 next to it) are Bluetooth, Microphone, Media&AppleMusic and BackgroundAppRefresh. Siri&Search and Notifications have further submenus.
    4. Make sure that at least the top three and the bottom one are turned on (green with the number 1 next to the button).

    Then you should see the Spark app listed under Settings/Privacy/Bluetooth.



  • @dhbailey Thanks. That's great feedback and very helpful. I think that we are now in the right area for solving the problem. I did what you suggested and after finding the Spark App there are only 3 things listed: Siri & Search, Notifications and Background App Refresh.
    Under Settings/Privacy/Bluetooth Sharing (there is no Bluetooth only Bluetooth Sharing) there are no Apps at all.
    I've uninstalled/re-installed the Spark App loads of times but this is all there ever is in Settings.
    Dealing by email with Support takes 'forever' because he is going through each step one at a time. So each step means an email followed by my reply, followed by another email, followed by my reply, followed by......etc. etc.
    So thanks again guys for all your help. It would be nice to hear from someone with an iPad Air 1 that has the Spark App installed to compare settings. There must be loads of people out there?



  • Support have now given me the previous Spark AMP Firmware 1.0.2.253 which I downloaded and installed. Unfortunately that didn't sort out the problem with my iPad Air 1.



  • After all testing it seemed that no IOS devices could connect to the Spark AMP using the Spark App. They have decided to send me a replacement. Fingers crossed that this works okay!
    **** UPDATE **** Got my new Spark AMP and it works okay. Hooray...!