Spark Amp Firmware v1.2.3.37 Beta



  • I was able to install the firmware today with little issues. I clicked install at first and nothing happened, turned the amp off and on again and all was good.

    I wasn’t able to get the app to connect to the amp all day yesterday, so far today things are working much better with the new firmware. Looking forward to hopefully never having to hear that awful sound on tone switch again!



  • @mike I also tried the update on a macbook pro running 10.15.4 Catalina. The result was the same...the update crashed.
    I downloaded the Windows version and updated the amp from a Windows 10 laptop.



  • Did this patch fix the sound levels when recording direct?



  • @tolosacrispinjr I received mine today and upgraded the firmware. Level is more than fine in Cubase under W10 OS
    Seems like the firmware fixes it ;)



  • Can confirm the volume levels are fixed for me.
    Using Mac and Garageband



  • @mike My issue is Bluetooth connectivity. Saw about enabling GPS. Most new Samsung devices don't have an explicit GPS setting, only advanced with enabling WiFi and Bluetooth (both enabled). I have three devices. My Samsung S9 originally and continues (with the new beta firmware) continues to work fine.

    The Samsung TabA 8 (the new model), didn't not previously work but after the beta firmware identified 2 Bluetooth connections. Spark 40 BLE (the original one) and a new one Spark 40 Audio. It paired and connected to the Spark with the Spark 40 Audio Bluetooth connection. So it is good to go (bigger screen than phone but trying to get to the larger tablet screen on the Tab S4.

    My Samsung Tab S4 had originally paired with the Spark, but the app never said it connected. I 'forgot' the pair. Now it never finds the pairing (with reboot of both device and spark). Same issue after the beta firmware update. Now just dealing with the Tab S4. I uninstalled the Spark app from the device. Rebooted and reinstalled the app. Turned off and back on the amp. So I get a pairing request. Then I get no device found. BUT, waited, and then it connected. Note that it is now connected with the Spark 40 Audio bluetooth connection. I guess this is a new bluetooth connection with the beta release. So Success on all 3 devices. Awesome. Thanks!!!!!



  • This post is deleted!


  • I have a IMac and the firmware would not pair with it. I trying everything. Turning on and off, restarting the computer, trying another USB cable. It just wouldn’t work and I’m a computer guy. So I hooked it up to my son’s Windows computer and boom, piece of cake. First time I’ve ever had something work on Windows and not a Mac.



  • I have a Mac that for various reasons is stuck running OSX10.9.5. The updater app won't run at all. I'm trying to find out what is the minimum OSX requirement for the updater so l can ask around to see where I can take my Spark to update it (when the COVID lockdown ends). Anyone know which version of OSX is the earliest I can use?



  • I have no problems connecting the Spark 40 to my iPad and iPod and also using the usb cable to the iMac where Garage Band recognizes and I have played through it many times but where do I find the "updater app"? In the Spark settings, I am at app version1.5.02463. Everything is working fine, but cannot find the updater app.

    UPDATE: My Spark 40 firmware is now updated.



  • @Mike

    my spark has crashed since my attempt to update the firmware.

    I started again 50 times, cutting the bluetooth, the antivirus, the
    firewall, etc.

    When I connect it to the update software, my serial number no longer appears
    and I get the message: Firmware update failed.

    All the LEDs flash on the Spark and there is no sound coming out of the
    speakers. He's just dead.

    Factory reset does not work either.

    I have send 2 support tickets but... no reply since 2 days...

    Thanks



  • @mike Can you update the firmware using a Chromebook?


  • Moderator

    @pitstop-com-fr Hi, could you let me know the ticket #? Thank you


  • Moderator

    @mikemayuke The Firmware updater can work on a Windows computer or a Mac only.



  • Hi there,
    Spark Amp Firmware updater simply does NOT work on my MacBook Pro (OSX Catalina). The computer properly recognises the amp, and shows it among the options in System Preferences --> Audio, but the Firmware Updater doesn't even seem to see it. I click on "Connect Hardware", the button darkens for a fraction of a second, and that's all. Tried everything: restart the amp, disconnect-reconnect the USB cable, change USB port, change USB adapter, reboot the computer (twice), change USB cable... Nothing.
    Any solution?
    Davide





  • @k-mcg said in Spark Amp Firmware v1.2.3.37 Beta:

    @drbaroni

    Try this:

    https://help.positivegrid.com/hc/en-us/articles/360045378291-Can-t-Open-Firmware-Updater-on-Mac-OSX-Catalina-

    Thank you, but the Updater opens normally. It just doesn't do what it's supposed to do... Actually, it doesn't seem to see the amp. :)
    But it opens just fine, thank you :)



  • @drbaroni I haven't tried it since I last updated, but last time I ended up booting to windows and saw the same issue. I ended up leaving the software open and powered the amp on and off a few times and one of those times it showed up. Wondering if it would work the same on the mac. At first I thought it was a security issue with drivers or something because I am on Catalina (and maybe it still is?).



  • @joshewah said in Spark Amp Firmware v1.2.3.37 Beta:

    @drbaroni I haven't tried it since I last updated, but last time I ended up booting to windows and saw the same issue. I ended up leaving the software open and powered the amp on and off a few times and one of those times it showed up. Wondering if it would work the same on the mac. At first I thought it was a security issue with drivers or something because I am on Catalina (and maybe it still is?).

    Well, Im on Catalina as well, and either it starts working or I'll have to wait for the next update of the Updater app. I don't know how many times I turned that hing on and off today :D
    And I don't have a Windows computer to try with, but as you said, if there's the same issue...



  • Bump.

    Topic had dropped to page 7.