This video is unavailable SPARK app error message



  • I just got my Spark. Every thing is working except the player. When I choose a pre installed backtrack the app plays it through the amp, and that is good, but when I choose a song that was already on my phone (imported from Apple Store) it gives an error message "This Video is unavailable" and does not play the song. It does show the chords, however. Has anyone experienced this? What is causing the error and how do I get it to play songs on my phone? I have an iPhone SE running iOS 13.4



  • Yes, I am experiencing the same thing.



  • ...same issue here, when trying to import a song from Spotify - strange enough, that the App tries to open the same song from YouTube and not Spotify...

    Any hint would be appreciated, App is up-to-date (1.4.4.2361 @iPadOS 13.5)



  • Same here cant play along to anything, but what is on the spark app.



  • Same problem... this appears to be a widespread issue as many members in the Facebook Spark group are reporting the same problem... i don’t think there’s been a software update so is this to do with permissions?



  • @tactobs same issue, have not been able to successfully play any song except for those preloaded into the Spark. Does anyone have any workarounds?



  • This isn’t going to help much as I am getting the same error message but the interesting thing is that this has only just started happening. It was all working perfectly a few days ago!



  • Someone on the Facebook group received a reply from PG that an app update is coming to fix this. "It could take 1-2 days for Apple to process the update". (which doesn't say they've submitted the update, but at least we know they're working on it...



  • Recent update did not fix this issue which is repeating update to udpate and VERY annoying. It removes 80% of why this amp is so good.

    They need to fix this. It makes the amp useless as far as I am concerned.



  • I uninstalled and reinstalled the app. Same issue. NO songs will play, it doesn't matter if I use Spotify or Apple. I loved this AMP but 98% of the reason was the chord display and it does not work half the time...right now all the time. Right now the Spark is a large paperweight.

    Very disappointing PG. Please fix this right away.



  • Same here, got mine two days ago and i'm really happy with the sound (after fixing the buzz and noise problem it has when slighly touching the strings). Took me some time to realize that you must open an account and must be logged in to get the app working with the amp. After managing those issues i'ts still not possible to playback songs via bluetooth from my iOS device. this should be fixed fast because the jamming feature is one of the main promises PG made!



  • New app update in Apple App Store. Somebody try it!



  • Applied the update and all now working from the iPad only - no music through the Spark Amp though :-(



  • Installed 1.4.5 update. Running on an iPhone (iOS 13.4.1). I have my backing tracks back. So far everything seems to be okay. I did get a lock up on the amp after trying a few of the tones in quick succession but up to that point the you tube backing tracks were playing correctly. Thanks to PG for sorting this out. For some reason, before this, I thought that when I downloaded a track, it was stored on my phone. I didn't realise I was still tied to YouTube.. Not totally happy with that as you tube videos do get taken down sometimes and I would hate to lose the best ones. Also means I can't use backing tracks without a good internet connection..still, glad to have them back for now!



  • @lapickbiz The Apple iOS update worked for me - now, I can use Spotify songs without receiving this error :)



  • Does not seem like they have fixed this problem. I loaded some songs from Spotify and a couple of them played. Then it stopped playing any of them, even the ones that had played. Like you describe here, it just shows the chords and says that there is no video. Will not play. Certainly this is a bug in the spark app.



  • @r_koby Not fixed! Had been working fine, and stopped. Same notes in Facebook users forum.



  • This is absolutely ridiculous. Every video I try, Not available. We need a permanent fix to this issue. I just snagged the latest YouTube App update, so it isn’t that.I just installled iOS 14.1 as troubleshooting.. latest and greatest. Rebooted, no joy after update. Still same error message “Video not available”



  • Not working for me either. Every video is unavailable.



  • Worked 2 days ago but not now! Any fix?