Problem Updating Spark Firmware



  • Has anyone successfully updated their Spark firmware on a Windows 10 computer? My desktop wont detect the Spark amp regardless of usb port/cable used. It does detect other usb devices with no problem. My laptop does detect it but states "usb device not recognized". I've reached out to support but haven't heard back yet.



  • Same problem here. Nor can I find the firmware updating tool



  • So, in the forum I found a link to v1.0.2.253 updater from 6 days ago (see below) and downloaded that. That updater enabled me to connect and update to that version. I have yet to find any link for v1.1.3.13. Where are they hiding all these firmware updates anyway? I'm just not feeling the excitement anymore but I'll give it time.

    https://drive.google.com/drive/folders/1sxcWeB64UoJU3BhqaR9GpMhMB0mx342y



  • @rstotty Hi. I updated the firmware to v1.0.2.253 but like you can see no link to update to v1.1.3.13 or anything else. I've been quite defensive of PG even though the customer service/delivery has been poor because their products are normally very good. I love this amp, but I am becoming disappointed in the responses. Software companies are not the best at communications, but are normally better than this.



  • @rstotty I've not even been able to find the app to install the firmware. Can't find a link anywhere!



  • @rstotty how the hell did you find that? I've been looking everywhere!



  • @tim-2 @rstotty Hopefully you will have seen the post in the forum now with the update on the Firmware to 1.1.3.13 from Mike. I'm going to update it a little bit later today. Whilst I'm happy to have a choice about when I do updates, it would be really good if there was some clear version control advice in the app. If people had just bought the amp and weren't that active on the forum they wouldn't have any idea about the firmware updates or where to find them.



  • @rstotty I have the same problem, tried on two Windows 10 machines, USB not recognized. Have you found a solution? Positive Grid, where are you?



  • I think if you want actual support you have to put in a support request.

    The firmware being linked here are beta and you should always try the latest one because what is the point in installing one with bugs that are already fixed. They really aren't obligated to give full support to a beta release, but having at least one person to interface with people and relay messages would be nice.

    I don't know what the heck is going on though, their whole office could be closed right now and people are working from home or who knows.

    That being said I am on a recent MacOS and it doesn't even work for me so I just have to wait.



  • I had the same issue. I put in a support ticket and they emailed me a link a couple days later. Unfortunately I'm also experiencing the grounding issue buzzing some people have



  • Seemed to connect fine with a Windows 10 machine for me. I did have a problem updating, but just started again and it seemed fine? I would recommend turning off the Bluetooth on anything it may be connected to while you do it. Also a power cycle on the amp, then reconnect USB cable (worked for me when it couldn't find it first time)