Crashes on 2.1.9



  • Hi. Bias FX crashes every time I switch scenes via BlueBoard MIDI controller. Playing is absolutely impossible - it crashes with every single scene switch :( If I'd need to use it for live performance I'd get into a lot of trouble

    The crash log is below:

    Process: BIAS FX 2 [8189]
    Path: /Applications/BIAS FX 2.app/Contents/MacOS/BIAS FX 2
    Identifier: com.positivegrid.BiasFx2Standalone
    Version: 2.1.9 (2.1.9.4885.Release)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: BIAS FX 2 [8189]
    User ID: 501

    Date/Time: 2020-04-11 23:29:15.673 +0300
    OS Version: Mac OS X 10.15.4 (19E287)
    Report Version: 12
    Bridge OS Version: 4.4 (17P4281)
    Anonymous UUID: C16B0CCA-0F22-432F-503F-EB44B028861B

    Sleep/Wake UUID: 9DC411B8-2A83-454F-BDDE-310B92BD55B0

    Time Awake Since Boot: 75000 seconds
    Time Since Wake: 41 seconds

    System Integrity Protection: enabled

    Crashed Thread: Unknown

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x00007bdbaafd0aa0
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [8189]

    Backtrace not available

    Unknown thread crashed with X86 Thread State (64-bit):
    rax: 0x00007bdbaafd0a80 rbx: 0x00007bdbaafd0a80 rcx: 0x00006000005f0a80 rdx: 0x0000000000000003
    rdi: 0x0000000000000000 rsi: 0x000070000b6b5770 rbp: 0x000070000b6b5760 rsp: 0x000070000b6b5720
    r8: 0x0000000000000073 r9: 0x00007fe542807fa6 r10: 0x00007fe542893000 r11: 0x00007fe542800000
    r12: 0x00006000021490a8 r13: 0x0000000000000001 r14: 0x0000000000000000 r15: 0x000060000052c1b0
    rip: 0x0000000209504bf0 rfl: 0x0000000000010202 cr2: 0x00007bdbaafd0aa0

    Logical CPU: 6
    Error Code: 0x00000004 (no mapping for user data read)
    Trap Number: 14

    Binary images description not available

    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 95008
    thread_create: 0
    thread_set_state: 0



  • ...Any ideas anybody?...



  • Ok, so I downgraded back to 2.1.8 and it still happens every time I switch the scene in my own preset - it just crashes right away 🙈


  • Moderator

    Here is a new beta - v2.1.10, please feel free to give it a try:

    Download v2.1.10.4890

    Release note:

    • Fixed the "duplicated presets issue"
    • Fixed the "ToneCloud preset issue"


  • @mike Thanks, but I'am on a Mac


  • Moderator

    @alexanderre I've updated the link above, thank you



  • So I have the latest version 2.1.10 and there is no change - as soon as I get the iRig connected and set it's buttons to switch between the scenes right after finishing button assignment as I press any button Bias crashes. It's really in a way of making the 300$ app any good, so please help me out with this one. I'll gladly provide crash logs if needed.