BIAS FX 2 "This preset requires BIAS AMP 2"



  • So there was an update today for 2.1.9. I just purchased BIAS FX 2 when it was on 2.1.8, and it appears from people's reply that it's a new business practice where you are now required to own BIAS AMP 2 for presets that were once opened in it. This was not always the case, however it's clear from the people's reply down below, that unfortunately we are required to spend more money for what once worked as is. I feel like we were betrayed. I feel like existing customers should be exempt from this. Though it's still shitty for future customers. I don't know how long these will be allowed but here's the link to the prior version if you already upgraded. I just downgraded and my presets work! Here is 2.1.8 version - BIAS FX2:
    Mac Standalone
    https://dlcf.positivegrid.com/BIAS_FX_2_Mac_Standalone_v2_1_8_4840.dmg
    Mac AAX
    https://dlcf.positivegrid.com/BIAS_FX_2_Mac_RTAS_AAX_Plugin_v2_1_8_4840.dmg
    Mac AU_VST
    https://dlcf.positivegrid.com/BIAS_FX_2_Mac_VST_AU_Plugin_v2_1_8_4840.dmg
    Windows 64bit
    https://dlcf.positivegrid.com/BIAS_FX_2_Windows64bit_v2_1_8_4840.msi
    Windows 32bit
    https://dlcf.positivegrid.com/BIAS_FX_2_Windows32bit_v2_1_8_4840.msi



  • @philminator Same here.

    EDIT: THERE'S A BUG FOR BIAS AMP 1 LITE OWNERS WHICH MAKES IT POSSIBLE TO USE BIAS AMP 1 AMPS, BUT MAKES IT IMPOSSIBLE TO USE IF SAVED. YOU'RE ALSO UNABLE TO DELETE THOSE PRESETS, SO UNTIL PG FIXES THIS, AVOID USING BIAS 1 AMPS IF YOU'RE A LITE USER.

    Bias AMP 1 Lite is from a giveaway by PG which removed the 30 second limit, it's NOT A DEMO.



  • @philminator: Same here after upgrading BIAS FX 2 Elite to 2.1.9.4885.Release version.



  • @michaeldymov Seems normal, in that someone else in the beta forum mentioned the same thing. So that means they pushed out the update officially, and that issue was not rectified. I wish there was a way to download prior versions of the software. Smh.



  • Same issue here. Presets that were working fine yesterday now saying they won't work without BIAS AMP. I can't find a single preset on ToneCloud that doesn't give me this error message.



  • @ric-levy Yeah it's frustrating. I just spent $150 on standard and metal pack and bought a new cheap guitar on sale for $500 and now I can't play the patches I was using last night. Hopefully this gets hotfixed ASAP, or an ability to re-download 2.1.8



  • Same issue for me. Just bought the software a few days ago so this sure was an unpleasant surprise.



  • @cmreal85 Indeed. The good news however is this is not normal behaviour. I was happy to find out you never require BIAS AMP to play a preset from someone else. I was scared I was gonna have to spend more $. I know Positive Grid is a great company, so hopefully they are aware of this, and won't be too long to fix it.



  • Me too. Had an Elite license for Bias fx2 for about a month.
    Downloaded update today and can't access half of my banked presets.



  • @v00doocat Yeah it really sucks. I know I keep complaining, but I've been procrastinating on and off for over 30 years playing the guitar. I'm starting to finally kinda get what I consider decent, and the immersion that BIAS FX 2 brings is out of this world, and I still have a few tones with the standard license and Metal pack, but yeah...I really want those darn presets I got from the tone cloud they are SO good. Right now I'm playing the presets from the preview window on the tone cloud lol.



  • same, i have bias fx2 pro, only just found this thread after posting the same thing a minute ago, oh well. If this is a cash grab i am going back to just using toontracks exclusively.



  • @1979lad I'm pretty sure it's a glitch as even in their FAQ I copied and pasted it states you don't need BIAS AMP 2 for any presets. It's an odd error indeed.



  • Same here . Hope the fixed it soon!



  • Same here. I purchased Bias Platinum and everything worked great as of this morning. As soon as i updated, I can't access anything from BIAS AMP 2 Elite. All the amps are missing, and when I select "already purchased?" from the menu after clicking on them, it just tells me I've logged into Elite and nothing happens. I was planning on tracking this weekend.. hopefully this is fixed soon.

    0_1586480256419_Capture2.JPG



  • Unfortunately, this is not a bug. I received this response from Positive Grid:

    "Since the 2.1.9 release, we've changed the policy on BIAS FX 2's ToneCloud licensing.
    The accessibility of the presets has been adjusted. From now on, the presets that contain BIAS Amp 2 content will be unavailable to those who do not own the respecting license. This is merely to reinforce the same principle across all additional contents (BIAS Amp 2, BIAS Pedal, Celestion, expansion packs) for BIAS FX 2.
    "



  • got the same response, they just lost a customer, i am going back to toontracks, bias can piss right off



  • @philminator looks like it is cash grab, got a response back from them saying they have changed the accessibility of the tonecloud stuff. Back to ToonTracks i go.



  • This is a joke, isn't it? I would understand if the filterd it now for the future in the tone cloud , ..but now, I've builded a lot of my own effects based on tonecloudds effect, ..and that's the idea behind a community cloud.
    and know the won't work any longer,?.. Ialthough it was announced differently in this own FAQs when the contract was concluded?

    Well..where is my older version?... Time Machine helps!



  • I reverted back to 2.1.8 and everything is back to normal . No "preset needs upgrade" messages whatsoever.
    Having stuff locked just because you upgraded to a "free" newer version is absurd.
    This is a case study on how companies can dissapoint happy customers overnight.



  • After updating to 2.1.9 had really slow loading time and when opening new amps very sluggish.
    Having gone back to 2.1.8 its much better, will stick with this version until they do some major fixs.

    Brian