Spark Amp Firmware v1.0.2.253 Beta

  • Hi all,
    I just received my Spark yesterday. I am using Spark Amp Version 1.2.197 and my Spark App version is I am having trouble ( I am a complete NOOB to this) connecting to Studio 4 Professional through an Audiobox USB interface. Are these the correct firmware versions I need to download and install? Both? One? Any help would be greatly appreciated.

  • OK! NP, opened my eyes and noticed the help section on my android. I found the answer....Spark amp can NOT connect two modes at once. Priority is AUX/USB/Bluetooth. So I now see my Guitar in Studio 4 pro. I have to fiddle with music volume and output on Spark to get correct volumes within my room. I also notice that it (Guitar) is low on input VU's but I just adjust (in my case a backing track) volume and it works great. Now I have not tried yet to record my passage and play it back. That will be later.

  • My iOS app says its at 1.4.1 (through app store not beta). Is there going to be a non-beta release of the firmware anytime soon?

    The app doesn't complain about the firmware version like the beta did, but the amp has been buggier lately (static that won't go away after I start playing some stuff from tone cloud, and problems connecting to the BTLE).
    The beta updater doesn't work on OSX Catalina, probably because its not signed properly. Only other choice I would have is use bootcamp to update in windows.

    Would be great if there was a way to upload the firmware via the iOS app, but that might not be possible with the hardware design.

  • @telestrats53
    Please follow my procedure below
    I've upgraded my spark's firmware on window10 system.

    1. Install ASIO driver without connection.
    2. connect usb cable (when spark power-off)
    3. open firmware updater
    4. spark power-on
    5. firmware upgrade.

    But, I failed firmware upgrade on MacOS. Firmware upgrade app cannot find my spark after rainbow circle in a minute, even the recording is working.(it must be connected.)

  • The download link for Android no longer works

  • @mike Any chance of providing a link to the v1.3 firmware. I have searched the site and cannot find it anywhere.

  • @edmit15 Hi. I received my Spark a few days ago (~April 23, 2020) and the Android app's "Spark Settings" page is telling me that it has firmware version installed.

    I'm a bit hesitant to install "beta" firmware so I think I'll wait until this release becomes official...

  • I think it would be a good idea to let readers know they cannot get the beta firmware without an invitation code, before telling them to install the Testflight software.

  • @timoggy-sales said in Spark Amp Firmware v1.0.2.253 Beta:

    @mike Any chance of providing a link to the v1.3 firmware. I have searched the site and cannot find it anywhere.

    As far as I understand you need the updated app to use the newer firmware. When this was first posted the beta app would prompt you to a link that had the firmware updater on it.

    Hopefully the process is streamlined in the future. I'm just going to wait it out. Most likely everyone is working remote now so I don't expect development to go at full speed.

  • Moderator

  • This post is deleted!

  • i saw on another post stating there is a newer firmware version now (already ;/) with a version number of Has anyone found this link or file yet?

  • @srfrdog thank you! I have seen a newer one posted on here this morning as well. Seems lots of bugs are being worked out.