Hearing BIAS FX in real time



  • Downloaded the demo, and like it enough to buy.....except for one thing: When recording, I'm getting nothing but the sound of the guitar plugged straight into the interface through the monitors or headphones. I have to play it back to hear what my chosen preset actually sounds like. I use Reaper, and I've checked and tweaked the routing numerous times and can't get BIAS sound when actually playing; only on playback. What up?



  • @ken You need these two things together:
    -in the guitar track you must have monitoring activated.
    -many interfaces allow to control how much direct monitoring versus software monitoring you want. You must be sure that you have software monitoring. That means you hear the signal after being processed by your DAW. If you have only direct monitoring, you will hear just the signal that goes into your interface, before it is sent to the DAW.



  • @korkenknopfus In my DAW (Reaper), the monitoring seems to be automatically on. I found software modelling in one of the drop downs, and Reaper applied it globally to all of the tracks. Am I missing something? And thanks for your reply.



  • @ken download this picture and study it carefully and set up like shown, also make sure you are using 1 audio interface for input/output (windows asio issue only)
    https://forum.positivegrid.com/topic/2676/bfx2-reaper-super-easy



  • @tafkad I've tried that with an audio track and it did not work, but it did not dawn on me to try it with a midi track, so I'll try it when I get home. Thanks!



  • @ken I think it is more about settings - this example allows midi control of Bias with a midi foot controller

    It sounds like you are using hardware monitoring instead of software monitoring and is the reason you are getting only unprocessed guitar when you play so make sure you are using the same soundcard for in/out and turn off any hardware monitoring and enable the software monitoring in reaper (check the little blue notation in the picture to see if you have set it up correctly

    here is a new picture of it in Catalina showing the popup for record monitoring on and should be all you need (turn off soundcard hardware monitoring if applicable)
    0_1580344636775_Screen Shot 2020-01-29 at 4.34.50 PM.png



  • @tafkad I wonder if I need to stop ignoring Reaper's prompts to udate, as I don't recall seeing that option on an individual track, only a global option in a drop down.



  • @tafkad said in Hearing BIAS FX in real time:

    It sounds like you are using hardware monitoring instead of software monitoring and is the reason you are getting only unprocessed guitar when you play

    ...and of course be sure that the interface self is monitoring software, too.



  • @ken overthinking it a little, start fresh like you never tried it before - the Red button on each track you make is the Record arm/disarm button - the little Speaker next to it is the record monitor toggle button - the popup comes when you hover the mouse curser over the little speaker and shows what state it is in - look at the mixer at the bottom and you can see the same 2 buttons for track #1 there (red circle with a speaker icon below it) - what soundcard are you using and have you made sure that you physically turned off the hardware monitoring on it? (some use a push button and some a mix knob to go blend between hardware/software monitoring and some come with control software that lets you turn off/on/blend hardware monitoring)

    If I open reaper, choose my soundcard, make a track, load BiasFX, and click the Red record arm button, sound comes out - if I click the little speaker icon next to the Red record button on the track (while stopped the whole time not even trying to record) it can be toggled on, auto and off - there is no other settings needed in Reaper (or any app) past that - if you are getting only guitar sound while stopped/playing/recording but get BiasFX after recording on playback then it is your soundcard hardware monitoring that needs to be physically disabled - here is my soundcards monitor control:
    0_1580390418506_IMG_4272.jpg
    you will get it and when you do you will be like okay that was too easy no wonder it was so hard : ] cheers



  • Thanks for all the help! It worked.

    Now how do I get rid of the latency?



  • @ken your interface should have its own software, where you can set the amount of samples. The lower the number, the better for latency, but the more forced is your processor. Try if you can work with 128, or less, for example. If you have problems, try 256. Low latency is important for recording or playing, but for mixing you can set again a bigger number of samples.