MainStage Sound Quality Issues



  • Has anyone ever had issues with BiasFX not loading properly when opening a concert file in MainStage? I've got BiasFX loaded into a bunch of channel strips/patches in a concert file, and when I open the concert they all sound very "tinny", but if I open each instance of BiasFX in the concert, the sound returns to normal.


  • A2

    I don't know about mainstage, but since the Gig Performer guys are on this very forum, I'd save yourself from pulling your hair out and take a look at that software instead (also its cross platform!)



  • @pipelineaudio Thanks, I'll check that out too! Would still like to figure out this MainStage thing because I'm in rehearsals for a show right now and don't exactly have time for new software... but definitely saving this for later.



  • @dmfyoung In FX2, I've found that this has to do with the Guitar Match feature getting saved into a bad state. For some reason the host (Mainstage in your case) is not getting updated information from FX2 even after you turn guitar match off and save the patch.

    What I've had to do is:

    • open up the standalone, delete my guitar match profiles for each of the presets in question and ensure the feature is turned off.

    • save each preset

    • open the host, delete and replace each of the instances of FX2

    • save the file in the host

    After that, it should be back to normal.



  • @dmfyoung I use Mainstage all the time. No issues.



  • This is one of our favorite videos by our friend Jeff, it has tips and tricks to help MainStage run at its best! https://youtu.be/otKMaHrYqr8
    Run MainStage in Edit mode rather than Perform mode, and see if Edit mode is less CPU-intensive for you.
    Run MainStage in low-resolution mode to minimize the impact on system performance: right-click on the MainStage application and select "Get Info". Then check the "Open in Low Resolution" checkbox.
    Disable the "Perform in Full Screen" option: Preferences > Display > Performance.
    Set your buffer to 256 or higher: Preferences > Audio > Advanced Settings > IO Buffer Size. Also check the "I/O Safety Buffer".
    Turn off Auto Save: Preferences > General > Autosaving > Never.
    Keep your desktop clean! https://computers.tutsplus.com/tutorials/why-you-shouldnt-store-files-on-the-desktop--cms-21721
    Turn off any icons running in your Mac's top menu bar. WiFi, Bluetooth, DropBox, etc can all eat away at available CPU and RAM.
    Keep your concert files from having too many patches. Every loaded patch consumes both RAM and CPU. Just keep the layered patches you are currently using. You can always export patches from MainStage, and load them back when needed. https://support.apple.com/kb/PH13627?locale=en_US
    Keep your audio levels from clipping, as it can cause CPU spikes and dropouts.