Bias Delay Pro Wet/Dry



  • First I was asking why the Bias Delay Pro pedal drops volume with amp's FX loop but, after some time tweaking the presets with my amp (TubeMeister 18) I realized the pedal is exponentially harder to tweak than I ever imagined. If I tweak the sounds with only clean channel and I get the levels to match the amp withouth boost/drop I can't use the same preset with Lead channel cause it clips like a mofo and makes the amp sound something it never was.

    How come there's no true wet/dry mix on the pedal/software? It's impossible to try and match the dealy sound with the amp's own sound. I mean, there's no pure delay, it always has its own color and no matter how hard I try to tweak it always eats sound like crazy. I've had several delay pedals and none of them ever had this issue. When I toggle the delay on, it makes the sound 100% different from dry. There's no middle ground. If I play riff for example and want to play solo with slight boost and delay, it's just not possible. Sound gets compressed, colored, saturated, twisted and cut down. I've even tried to make boosted delay sound but it's still always lacking. It's like putting -3dB diode pre-amp in FX loop when using lead/crunch/OD channel.

    Am I the only one with this problem?


  • Moderator

    @anamorphica Can you try to set the pedal to True Bypass mode to see how it goes? (Hold down footswitch A and plug in the power to switch to True Bypass Mode. )



  • This post is deleted!


  • @felix I have it on true bypass and it has nothing to do with this. Pedal doesn't affect the sound of the amp when bypassed. I'm talking about how it smashes and alters the sound fully when not on bypass. I just can't achieve any transparency to it.

    I was just wondering if there's any way to get true wet/dry mix on this pedal. When mod and mix is set to 0% it's still altering the sound 100% just not with delay or modulation.


  • Moderator

    @anamorphica There's no wet/dry function on the pedal, but FWIK you should get the original dry signal when mix/mod knobs are set to zero, can you record a video and send it through suppoort@positivegrid.com, we will follow this up!