Bias Fx 2 Crash in cubase pro 9.5, direct signal issue and other


  • A2

    Hey guys,
    after the last bias fx 2 update, once I attempt to load Bias FX 2 on an empty audio track, Cubase crash....but only if there are other midi tracks or audio tracks already loaded in the project

    Also, I can't get rid of direct signal of the guitar when using Bias FX 2 in cubase.
    Actually I can hear at the same time the direct and dry signal from my guitar and effected signal coming from bias fx

    other thing:
    the timing of the fx's does not work properly.
    For instance the Echotape set at 500ms sounds like a 150ms...similar problem experienced with other timing fx's like tremolo

    What hell is goin on??

    p.s.
    No problem with the standalone version



  • @salvatore-di-piazza said in Bias Fx 2 Crash in cubase pro 9.5, direct signal issue and other:

    Also, I can't get rid of direct signal of the guitar when using Bias FX 2 in cubase.
    Actually I can hear at the same time the direct and dry signal from my guitar and effected signal coming from bias fx

    That sounds like you either have Direct Monitoring enabled, or your interface has a similar feature that is enabled. If you only want to hear the effected signal, make sure all your direct interface monitoring is muted.

    other thing:
    the timing of the fx's does not work properly.
    For instance the Echotape set at 500ms sounds like a 150ms...similar problem experienced with other timing fx's like tremolo

    Are you sure you the pedal isn't in Sync mode?


  • A2

    the crash issue remains, after I've open an older project (previous to the update) which works just fine, new projects now behave correctly, no more timing problems, no more direct signal..