New User Looking For Some Help With Bias FX 2 & Logic Pro X



  • Hi there,

    I've searched online and the forum here but I can't find an answer to this problem. I'm really hoping you can help me as I'm starting to get really frustrated with it all.

    I'm using Logic Pro X with a Roland Quad Capture interface and have had no problems recording previously with my guitar straight into the interface using Logic's on board amp sims. In fact some of them don't sound half bad.

    Anyway I thought I'd purchase Bias FX2 and it's installed just fine. I can open it up within Logic but there's no input showing from my guitar. The interface shows level going into it, and if I record straight into logic it records just fine. I'm opening Bias FX as a new software instrument and the input shows as Bias FX, the outputs as 1&2. I've authenticated Bias by logging into the tone cloud via the settings cog icon but no joy. Bias shows up in the Preferences of Logic under Plugin Manager and is ticked.

    I know I'm missing something really stupid and I'm really sorry if this question has been asked before; I couldn't find it using the forum search.

    Can anybody please help me?

    Cheers,

    Neil.





  • @tafkad thanks for your reply but none of those seem to help me, I'm afraid.



  • @neilfatmonkey then you are going to need to be more exacting in your request, add pictures of what you are seeing and what you are doing - notate them if needed - maybe it is something easily spotted - cheers

    that first "how to link" above shows exactly how to use Bias FX as a "Midi Controlled AU" loaded in an "Instrument" slot - there is other methods

    If you can use you interface with Logic to get audio working the way you want with the built in guitar amp sims then there is a solution (Bias is not broken that way)



  • You don’t setup Bias as a new software Instrument. You create an audio track and load Bias as in the FX section and set the input of the track to input of your card that the guitar goes into, it’s dirt simple.

    Use an example project that has the Logic Amp models loaded already or something and just right click the FX where the modeler is loaded and switch it for Bias if the above is not clear...

    You could actually do the above in Garage Band to get the gist because GB is like a very light version of Logic.



  • New User Looking For Some Help With Bias FX 2 & Logic Pro X:

    You don’t setup Bias as a new software Instrument. You create an audio track and load Bias as in the FX section and set the input of the track to input of your card that the guitar goes into, it’s dirt simple.

    correct AND incorrect at the same time - again quote:

    "... how to use Bias FX as a "Midi Controlled AU" loaded in an "Instrument" slot - there is other methods"

    IF you want easy full MIDI control of Bias in Logic I suggest this as the start:

    0_1560010117945_Instrument Track.png

    If you want something like @elric said then by all means start here (most likely you did):

    0_1560010183304_Audio Track.png

    both will get you there which "getting there (audio IN)" was never your issue with Logic Amps - so the issue is some setting with either Logc - OSX - or BIAS and whatever that setting is that is stopping you just needs to be identified so you can rock on (check "privacy/security" sttings in OSX for Bias to have access to the Microphone just to be sure)



  • @elric thank you so much. I could have sworn this is what I was doing already but now I have sound, which is all I need for now to start recording. I'll work all the other stuff out in slow time.

    Thank you again from this total biff. Cheers.

    Neil.



  • @neilfatmonkey said in New User Looking For Some Help With Bias FX 2 & Logic Pro X:

    @elric thank you so much. I could have sworn this is what I was doing already but now I have sound, which is all I need for now to start recording. I'll work all the other stuff out in slow time.

    Thank you again from this total biff. Cheers.

    Neil.

    Awesome! Glad it is working for you!