MeloAudio MIDI Commander with BIAS FX compatibility issues.



  • I have MIDI Commander designed by MeloAudio. It's compatible with BIAS FX. But I have a number of problems. The only working use case is setting MIDI source number manually choosing it from MIDI sources drop down list.
    But what is not working as I expected:

    1. Click Settings button in top right of screen and go as follows wat MIDI Settings -> MIDI Control Assignments -> Click ADD NEW CONTROL ASSIGNMENTS.... Choose Preset -> Preset+ for example. You will see pop-up with MIDI LEARN button. As I know it should be clicked and then I should press any switch on my MIDI commander. But unfortunately nothing happens and I see error message "No midi received in 5 secs".
    2. I tried to use MIDI commander with BIAS FX Plug-in but it doesn't respond at all. And BIAS FX Plug-in doesn't have have Audio Settings (it should have a setting to choose Active MIDI Inputs)
    3. There is a delay during switching between presets

    Has anybody used MeloAudio MIDI Commander with BIAS FX and faced the same problems?

    PS. I connect MIDI Commander to MacOS


  • Moderator

    @dsm87-sergey Can you check if the MeloAudio and BIAS FX are sharing the same MIDI channel? You can download MIDI Monitor app to check:
    https://www.snoize.com/MIDIMonitor/

    Check out our Help Center to setup MIDI setting with BIAS FX Plugin version:
    https://help.positivegrid.com/hc/en-us/categories/200409255



  • @dsm87-sergey said in MeloAudio MIDI Commander with BIAS FX compatibility issues.:

    I have MIDI Commander designed by MeloAudio. It's compatible with BIAS FX. But I have a number of problems. The only working use case is setting MIDI source number manually choosing it from MIDI sources drop down list.
    But what is not working as I expected:

    1. Click Settings button in top right of screen and go as follows wat MIDI Settings -> MIDI Control Assignments -> Click ADD NEW CONTROL ASSIGNMENTS.... Choose Preset -> Preset+ for example. You will see pop-up with MIDI LEARN button. As I know it should be clicked and then I should press any switch on my MIDI commander. But unfortunately nothing happens and I see error message "No midi received in 5 secs".
    2. I tried to use MIDI commander with BIAS FX Plug-in but it doesn't respond at all. And BIAS FX Plug-in doesn't have have Audio Settings (it should have a setting to choose Active MIDI Inputs)
    3. There is a delay during switching between presets

    Has anybody used MeloAudio MIDI Commander with BIAS FX and faced the same problems?

    PS. I connect MIDI Commander to MacOS

    Hi. I am using the same midi commander from Meloaudio.
    Mainly i am using it with bias fx on ipad and works ok.

    the #1 you are talking about, i have the same behavior.
    The only way to make it work is to assign manually the preset number on each patch.
    Example.
    Bank with 8 presets.
    you have to assign 0-3 for the 1st 4 row presets and 4-7 for the next row, manually by editing each preset.

    to change to preset 5 for example, you have to press the up button on meloaudio, this will switch to preset 5.
    if you want to change, lets say to 6 you have to press also the button 3 on meloaudio.

    This means you are passing by another preset before the correct one. This is the main issue.
    As i know the meloaudio has a custom setup also. I tried that also with no success.

    For changing bank, i havent found any way to do it. i believe it is not working at all.

    ps. i am using windows 10.



  • ok, i found something from the meloaudio manual.
    https://drive.google.com/file/d/1FCevouOx5HqhReFVoMOgyiRbVt0FMj2v/view

    Parameter 3, Option WAI, IMM
    WAI represents that it does not jump immediately after the patches change, waiting for patch jumping in new group
    after pressed footswitch, and the screen is flickering. IMM represents jumping to the 1st patch of next group immediately

    so i will test the IMM mode.



  • Ok, just tested it and it works.
    You have to load the custom host setup mode.
    Press the down button and power on the meloaudio.
    next press down to go the CUS1 mode.
    Select bank mode and press C to change to WAI.
    Turn off.
    Load the CUS1 mode by pressing button C and power on the meloaudio.

    after this when you press the up/down buttons to change preset row, it does not go to the 1st on the row but it waits to press the exact patch you want to load.

    Hope it helps.



  • @dsm87-sergey I have MeloAudiomidi COmmander and its working without problems, its very great controller. For me its better than Behringer FCB010, which is now old school looking. But the main benefit for Meloaudio than Behringer is the size. ANother thing: When I used Behringer for turning on/off pedals in Bias FX, only the one number shined-only the last switching. But melloaudio: numbers which are on are shining/effects which are on are shining, its much more better.



  • Hi there, sorry...maybe a bit offtopic...

    When you change preset, does it reset (turn off) all the engaged button?

    So far I use the Line6 FBV Express MKII as midi controller for Bias Fx, I love it especially for its lightweight and integrated expression/whawha pedal, but everytime you change preset it does not reset the engaged button, so it makes some mess with ON/OFF of each effect.

    Thanks for any reply.



  • @andrea-pianobar said in MeloAudio MIDI Commander with BIAS FX compatibility issues.:

    Hi there, sorry...maybe a bit offtopic...

    When you change preset, does it reset (turn off) all the engaged button?

    If I understand you right, then yes: if you are in a patch and with a button you turn on a delay, for example, when you change the patch, the button that activated the delay goes off in the new patch.



  • Like @Korkenknopfus I have this controller too and am loving it with my iPad Pro 10.5". Really nice all in one interface and controller.