Latency Questions from a Newbie



  • Hey Guys, I'm pretty new to the world of modern software effects, recording, etc., so please excuse the basic-ness of this post. Here's the situation. I bought the Bias Fx Pro, Amp Elite, and Metal Expansion pack on Black Friday. I also bought a new computer (Windows 10, I7 Core, 8G Ram) to dedicate to my Positive Grid stuff. I'm using a Line 6 Toneport UX1 as my interface, which I understand is a very old interface.

    When I plug everything in, it sounds amazing, even with the factory presets. However, I can't get rid of the latency. I hit the strings, and I don't hear the output until a rather substantial delay. The web site says I need an "audio interface with low-latency ASIO driver." Does that mean I need a 1) different, more modern USB interface, instead of my Toneport UX1, 2) A sound card in my PC that will enable less latency, or 3) a different driver for my UX1? I don't think any newer drivers exist, so if it's 3), I think I'm out of luck.

    Again, I'm sorry if this question has been asked a trillion time; I'm just not savvy enough to understand a lot just yet.

    Kenny



  • I don't know anything about the UX1, but what you need to do is set the audio settings in BFX (if you are using the stand alone, otherwise in your DAW), if you haven't done already. You need to choose your interface (the UX1) through ASIO. Then you set the sample rate at 44.1 kHz (you can test higher values later), and the audio buffer size at 512.
    Later you can try higher kHz and lower buffer sizes and see if it works (for less latency).



  • @john Beautiful, thanks John. I'll try that ASAP.


  • A2

    The UX1 was from a driver family that seems to include the XT Live, KB37 and that early series. These are fully featured audio interface drivers quite unlike most (or all? Not sure havent tried the Helix driver yet) of the modern drivers. Its not the fastest out there, but is quite good, and in ASIO mode should do very well, unless you are one of those nutty latency purists who cripple themselves trying to go far beyond even what they can perceive as latency



  • @pipelineaudio haha : ]



  • @pipelineaudio Thanks pipeline. The problem I'm having now is that there appears to be an issue with the UX1 related to ASIO. When I try to select the Line 6 UX1 in the input menu, I get "ASIO Driver open Failure!" message. So as of now, I don't see any way to use it in ASIO mode. I tried downloading the ASIO4ALL drivers, and got the same message. It's probably user error, but right now I can't figure out a way forward. I'll keep trying; if you have any thoughts I would greatly appreciate it.



  • @kenny pipelineaudio may well have better answers, but I would go to the Device Manager in windows and uninstall the UX1. Then I'd restart the computer without the UX1 attached, reinstall the UX1-ASIO driver (from Line 6 website), restart once more (which is probably totally unnecessary). Now the time has come to plug in the interface and should work (maybe).


  • A2

    Id do what john says, after making sure nothing else is using the asio driver. You can check that by seeing if it works in a reliable ASIO daw. Make sure you got all that working in a daw, where you will usually have more options to test, then make sure you can run bias as a vst in that daw, then try it standalone



  • @pipelineaudio Thanks so much guys; I really appreciate it. Told you I was new, so here is an embarrassing question. What is a DAW? Is that the recording software that shows the individual tracks and is used for mixing, like Ableton? Right now I'm not using one of those. I'm going from my Line 6 UX1 into the USB port, into Bias FX, then I listen to the result in my headphones. I don't have any recording software in the line. I still can't get rid of the "ASIO Driver open Failure" message.


  • A2

    @kenny Yup, thats what a DAW is...Grab a free, easy to use demo of one so you can test it.



  • @kenny Pipelineaudio means pick Cockos Reaper, but he doesn't dare say it because of affiliation. It's a good idea though. Very testable before buying, and it's good. Maybe you will prefer something else (people like different things) but until then it works fine and has good video tutorials. I'm rather new at this but Reaper has tought me a lot.



  • @john Thanks John. I appreciate the suggestion. I'll start there.



  • Guys, thanks so much, it appears to be working now. It was a combination of things, but after many iterations of uninstalling, reinstalling, and restarts, it finally came up. Honestly, at this point I don't know exactly what made it work, but I'm in low-latency ASIO mode, and I'm a happy dude. John and piplineaudio, I owe you both!