Bias FX resets to default settings after exiting DAW (Cakewalk)



  • So since Positive Grid isn't going to respond to my email for a while, and I can't find any answers online, I will ask here...

    I just purchased the Bias Guitar Essentials which included Bias Amp 2 Pro and Bias FX pro. When I add Bias Amp 2 into a track and load up my amp settings, it acts as normal, and I can quit Cakewalk by Bandlab and work on my project later. Bias FX however, will NOT remember what settings were on each individual guitar track after I quit the DAW. I have tried everything including uninstalling anything related to Positive Grid and reinstalling fresh and still nothing. This is annoying since I have projects from before that I do not have the presets saved so I am screwed now. So far I am not impressed, we'll see how Positive Grid responds to my email and if they can help me fix this. Expensive software to be malfunctioning like that. I appreciate any ideas or help I can get from anyone, thank you.


  • A2

    What happens if you save the setup to a new preset? It should definitely save your settings though. As many quibbles as I have with it in reaper, it still keeps its settings fine



  • @pipelineaudio It's strange because I've been working with Bias FX standard for months now and it worked fine. When I upgraded today it was working fine as well but then all of a sudden nothing.



  • I haven't experienced any such problems in Studio One 3/4 Pro or REAPER, I haven't used SONAR since switching over to Studio One nearly 3 years ago, but can't recall any issues, haven't used CbB and don't intend to. Do you have SONAR Platinum? If so what happens when you use BIAS FX in that?. After my backup finishes I'll fire up SONAR Platinum and try it out and see what happens, I wouldn't be so quick to lay the blame on PG though, Cakewalk has a long history of being flaky and buggy, and there are quite a few folks having various problems with the new BandLab stuff on their forums, and it is 'Freeware' after all, that's just how it is.



  • @offthegrid I tried to load it up in Sonar Platinum and it does the same thing. The issue seems to lie within the updated software. I think not deleting the old Bias FX and just letting FX Pro overwrite it screwed everything up, but I even tried a clean install. I tried restarting my computer, tried in a fresh project that never used the older version of FX and still nothing. The thing is after I upgraded to pro I was working all afternoon with it and it was fine, after exporting my audio that's when I noticed any project I opened and played had all dry/clean guitars and is freaked me out. EVERY project. It's weird.



  • I just tried with SONAR Platinum, the latest and last release before they shut down, and it works fine for me. If you go to the Cakewalk forums and search, you will see posts/threads by a user by the name of sharke (there are others) dealing with plugins of various nature loosing their settings in SONAR Platinum, there were quite a few people who came forward experiencing the issue once he started posting about it, most of these posts and threads came in the time between Cakewalk being closed and the BandLab acquisition.

    Have you tried it in another DAW besides SONAR Platinum or CbB? If you don't have another you can download REAPER, fully functioning, non expiring demo, only about 11mb to try.

    When you uninstall your BIAS FX Pro, do you find and delete all the relevant folders/files in various places and then reboot before reinstalling?



  • also, if you do happen to want to search posts on the Cakewalk forums, the forums are ironically bugged out to the eyeballs and the search function doesn't work very well if at all. You can do a google search restricted to the forums by entering the following in the google search field.

    site:forum.cakewalk.com keyword(s)

    where you replace keywords(s) . . . with your search terms.



  • A few examples of plugins not retaining settings within SONAR, there are many more, some have been deleted as they got to hot for the powers that be.

    http://forum.cakewalk.com/FindPost/3732101

    http://forum.cakewalk.com/Well-once-again-Sonar-has-destroyed-one-of-my-synths-m3722430.aspx

    http://forum.cakewalk.com/Another-plugin-losing-its-settings-Ozone-Imager-m3711404.aspx

    http://forum.cakewalk.com/Possible-fix-for-plugin-settings-not-being-saved-m3723084.aspx

    The user sharke has since ditched SONAR (as have many other long time users) and now uses REAPER.


  • A2

    I'm usually known for tilting at windmills to try and get things to work in some roundabout, workaround way, but looking at these threads, even the guys I often look to as fellow Quixotes have thrown in the towel

    As mentioned above, maybe in not so many words, but....You usually want to see at some point whether the issue is OS related or hardware related or host related

    Try it in another host, just to be sure



  • @offthegrid This is interesting, I have not found anyone else with the same problems but I can try another DAW I suppose. I've been familiar with Sonar for years though. As for the deleting all relevant files and restarting, I have tried that. Positive Grid responded to me about 24 hours after the ticket was submitted saying they are still looking into it. I have a feeling they're gonna start with simple things like "factory reset, try rebooting, try reinstalling" and then take another 24+ hours to respond to me telling them I already tried that.

    I think I will try it in Reaper though just to see if it's DAW related. Thanks for the suggestion!



  • Just to recap though everyone, Bias Amp Pro and Bias FX Standard worked fine for months. I upgraded to Bias Amp 2 Pro and Bias FX Pro. Both were working without issue that morning and through most of the afternoon. After I quit my project for the day and opened it up in the evening I noticed the playback was all dry signals, I had to go into my Bias FX tracks and open up my saved presets again. It's not a deal breaker for me but I am very particular with my work station and like to have everything ready to go. At some point the change from FX STD to FX PRO messed it up, and Bias Amp 2 works just fine.



  • @offthegrid Aw man, unfortunately it does the same thing in Reaper. I may have screwed up my Bias by not properly uninstalling the old one the first time. I have been doing that since but I am wondering now if I should have removed the FX STD right from the start before installing. Hopefully Positive Grid has a fix for this.



  • SOLVED

    Update guys, I found two lingering files in MY DOCUMENTS where the banks are saved and also a LICENSE FILE. I notice when I uninstall Bias FX it always tells me it failed to deactivate license or something along those lines. It seems as though removing this and every other Bias FX related file, then rebooting, then reinstalling solved this issue. I would like to keep this up so that people with similar issues may find some relief.



  • Yes, any files left behind after uninstall can cause problems in certain situations, sometimes they are removed after reboot, sometimes not, I always seek out and destroy all related files and folders, reg entries I can if I uninstall something, which I try not to do on my main DAW Pc's, I like to keep them as clean as possible and install any demo's etc, or things I may not keep on a test machine so it doesn't 'pollute' my main DAW PC's. If uninstalls worked completely leaving your machine exactly as it was before installation it would be good, but I think that could get very complicated and time consuming and perhaps the reason why it doesn't happen very often.

    Glad you got it sorted.



  • On a related note, I apologize, I forgot to mention if you were to install REAPER, choosing the Portable install option would leave your PC as it was before install when you remove it, as it is all self contained, just remove the folder and it's gone.