Something went wrong during the maintenance. Some of the profile icons might be missing. Please re-upload your profile icons if this is the case. Sorry for the inconvenience.

Bias FX Windows Installer Problem



  • Hi everybody,
    I recently have a problem while trying to run the software.
    A pop-up window comes up and says: "Installation is being prepared." This problem seems to appera only with Bias FX. Other programs such as Audacity, Cubase run without a problem.

    I've tried several things such as uninstalling the 64bit version and installing the 32bit or running the program as an administrator.
    Re-registering and re-installing the windows installer. Didn't help.

    Maybe some of you had the same problem. It would be great if you could help me.

    Thanks
    Burak



  • This step plus the cleanup-process can take up to 20 minutes on my WIN10 system.
    Never have seen such a long installation process on a application before, but finally it works for me :/



  • That slowness has totally disappeared on my system. I thought it was the new versions that were faster, but I have changed two other things, I just don't know when the big change was. The two other things were moving the OS to an SSD and changing from Avast to Malwarebytes combined with Windows Defender.



  • Let's recall, that only the PG installers are causing this coffee break. I am using just the internal safety tools of WIN10 and my HD is not the slowest one.



  • BIAS FX is already installed on the SSD and I've deactivated the anti-virus program (ESET) but it is still stuck at that step doesn't procede from that point. :(



  • @sascha-ballweg said in Bias FX Windows Installer Problem:

    Let's recall, that only the PG installers are causing this coffee break. I am using just the internal safety tools of WIN10 and my HD is not the slowest one.

    Yes. Only the PG installers.
    Other programs run normally.



  • Then you better open a ticket



  • I did.
    It was functioning properly a month ago.



  • @sascha-ballweg said in Bias FX Windows Installer Problem:

    This step plus the cleanup-process can take up to 20 minutes on my WIN10 system.
    Never have seen such a long installation process on a application before, but finally it works for me :/

    I have always experienced this with all PG products (although not to the extent of 20 minutes, 20 minutes would see me part ways with PG) maybe around 5 minutes, BIAS Fx Pro being the worst and then BIAS Amp Pro/Amp2 Pro being slightly quicker, and then BIAS Pedal being slightly quicker again, and then the Comps and Eq's being quicker again, but all display the same symptoms, long installs, they all sit on checking disk space or whatever words they use for a good amount of time, then they kick off with a couple of other lesser 'sticking points'. I have no AV installed except the built in Windows 10. Don't have this issue with any other programs, only PG products. I just learned to put up with it because I liked the sound and end result better with PG products, but have come close a couple of times to ditching PG altogether. Apart from the slow install there is slow loading of all PG products (compared to everything else) whether it be within a DAW or standalone, comparatively sluggish GUI's and browsers, sub-par preset management and selection both in terms of functionality and speed compared to others, and other issues they have had from time to time with updates requiring investigation and/or rolling back to a previous version, like with the latest BIAS Fx Pro, and the GUI whiting out after about 10 seconds. But I'm still hanging in there, it's still worth it to me even with these issues, but that could change in the future. I own pretty much everything else software amp sim wise, and while the BIAS group is my fav, I could quite easily and comfortably switch back to another, time will tell.



  • Well, after messing around with some of my other Amp sims, I have decided to part ways with PG products, the difference is not that great, and some of the others seem to have a quality to their sound which could be seen as 'more amp like', and they all are less system taxing, much faster in loading and navigating the GUI, preset selection/management is far superior and faster, none of the other issue like with slow installation etc. A shame, but I would rather the less complication, less stress, less issue path now, lot of money down the tubes, I had all the PG products available for Windows, and purchased the complete Choptones catalogue of amps for BIAS, but it was fun while it lasted. ALl the best to you all, it's a great product, just a few to many 'issues' to deal with for me.



  • The problem was caused by outdated Yamaha Steinberg drivers.
    I've found this solution by fooling around and not with the help of the technical support.
    Maybe this helps someone in the future.
    Cheers



  • This post is deleted!


  • @ said in Bias FX Windows Installer Problem:

    Well, after messing around with some of my other Amp sims, I have decided to part ways with PG products, just a few to many 'issues' to deal with for me.

    You’ll be back. Battered woman syndrome-type thing. I know I have it bad.



  • People forget that supporting function in various, let alone all, DAWs and VST hosts is a daunting, and obviously not trivial, task.